can't detect mediatomb server from windows

Help
dudlx
2006-06-30
2013-05-30
  • dudlx

    dudlx - 2006-06-30

    Hi,

    1.I run mediatomb-0.8.1(or in daemon) on my linux Fedora Corer 4 cuccessfully without bug, but I can't detect it in my Windows XP sp2 with UPnP on.

    By the way, I installed libupnp-1.3.1 and my windows XP operation system with same setting can detect my D-Link "airPlus Xtreme G Wireless Storage Router" successfully, so I think it's the problems of my mediatomb, maybe I didn't set or run mediatomb in right way, I don't know.

    So would anyone help me to run it in right way or make it can be detected and work with my windows XP sp2 operation system?

    I didn't find any mediatomb manual of operation, is there any one, please tell me.

    2.When it can't be detected in windows, I installed djmount-0.53(a upnp client) and fuse-2.5.3(need by djmount) in my Linux with mediatomb-0.8.1 for test.
    firstly, I run my mediatomb in daemon, and then run fuse and djmount successfully. Use "djmount", I pointed “/mnt/upnp” as a mount point. I can get into the directory of "/mnt/upnp/MediaTomb (localhost.localdomain) _ root/browse/PC Directory" successfully. And I can find my music, but I can't run them and the music file names are ended with ".m3u" or "xml". Such as "1.wma.m3u" and with file "1.wma.xml".
    The content of these files as below:
    "1.wma.m3u":
    #EXTM3U
    #EXTINF:-1,1.wma
    http://10.0.0.111:49152/content/media?object_id=55&res_id=0
    "1.wma.xml":
    <?xml version="1.0" encoding="UTF-8"?>
    <item id="55" parentID="4" restricted="1">
    <dc:title>1.wma</dc:title>
    <upnp:class>object.item.audioItem</upnp:class>
    <res protocolInfo="http-get:*:audio/x-ms-wma:*">http://10.0.0.111:49152/content/media?object_id=55&amp;res_id=0</res>
    </item>

    I think the content of files maybe right, but I don't know how to run my music, so could anyone can help me?

    Regards,
    dudlx

     
    • Jin

      Jin - 2006-07-02

      hi,

      well, first question: are you sure the multicast settings were properly applied on the network interface where the server is running?

      since you are seeing other UPnP devices I assume that your windows firewall is not blocking UDP port 1900?

      what software on your windows PC are you using to stream from the server?

      usually you need a mediarenderer, allthough you could probably use the m3u lists created by djmount with WinAMP.

      you could also download Intel UPnP Tools (they are free) and do some debugging, see if Intel Tools can find the server.

      Greetings,
      Jin

       
    • dudlx

      dudlx - 2006-07-14

      Hi jin,

      Thanks for your help first of all.

      As your replied information, I checked my system enviroment, all were OK.
      And I'm playing with Intel UPnP Tools about one week, now I can find the content directory through Intel UPnP MedaiController and Mediarenderer, but still I can't play the audio and video files which I can see in MediaController and Mediarenderer. When I select an audio file through MediaController and  click mouse "lift", then select "send to Intel Media Renderer" to play the audio file, but it seems dosen't work.
      I captured the communication data through "Sniffer". And by check the data, I only find the communication data of NOTIFY, M-SEARCH, and the data to request and response to get the directory content. But no further control information or event data was found.
      I don't why and where it stopped to work.
      Eager for your help.

      Regards,
      dudlx

       
      • Nektarios K. Papadopoulos

        I used to have trouble playing any content with the Intel Media Renderer (not just from MediaTomb). I never actually resolved the issue. Everything worked fine after a HDD crash last December and reinstalling everything.

        Can you server media content from the Intel MediaServer to the MediaRenderer ?

        Have you tried other tools, e.g. cidero[1] ?

        [1]http://www.cidero.com/index.html

         
    • Jin

      Jin - 2006-07-16

      if you want to capture complete communication between MediaTomb and other UPnP devices/control points I suggest that you run ethereal on your linux machine (on the one where mediatomb is running)

      I am not familiar with the Intel Media Renderer, so can't tell you much. I know the AV Media Controller allows you to open a link in browser, maybe you could try that and see if data is being downloaded from the server.

      Greetings,
      Jin

       
    • dudlx

      dudlx - 2006-07-17

      Hi,

      Thanks to jin and Nektarios K.Papadopoulos!

      Now with your help I have fixed this problem, and with MediaTomb and Intel tools I can play wav,mp3,avi,mpg and so on. In order to play with UPnP media file, must use Intel Media Controller and Intel Media Renderer tools together, Intel Media Controller to get the URL and pass to Renderer, then use the Renderer to play by clicking the play button. If only use Renderer or Controller, it will not work. Indeed intel tools are not easy to use.I will try cidero.

      Suggestion:
      With Mediatomb I have a suggestion that I hope Mediatomb can sort the files in share path.
      Only display out the media files Mediatomb supported, and hidden the files not supportd.

      regards,
      dudlx

       

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks