PS3 flac transcoding

  • lassel

    lassel - 2010-11-23


    I've installed MediaTomb on my Western Digital World Edition NAS, using this command:

    ipkg install MediaTomb
    All works well and I can see MediaTomb from PS3

    I have my hole music collection in flac format which PS3 is unable to play. I would like to have help to set transcoding so that I can play my music using PS3 and also enable thumbnails.

    I've followed examples on Internet,, but no one works for me. PS3 finds the songs,, but only "plays" them for a second,, then goes to next song, etc.

    Anyone that can help me?


  • airflow

    airflow - 2010-11-26


    how exactly did you try it? Can you post the transcoding-profile you used?

    I got this solved by using the following profile:

          <profile name="oggflac2PS3-format" enabled="no" type="external">
            <agent command="ogg123" arguments="-d raw -o byteorder:big -f %out %in"/>
            <buffer size="1048576" chunk-size="13100" fill-size="262144"/>

    Kind Regards,

  • lassel

    lassel - 2010-11-26

    My Config.

    <?xml version="1.0" encoding="UTF-8"?>
    <config version="1" xmlns="" xmlns:xsi="" $
        <ui enabled="yes">
          <accounts enabled="no" session-timeout="30">
            <account user="mediatomb" password="mediatomb"/>
          <sqlite3 enabled="yes">
        <protocolInfo extend="yes"/>
        <!-- For PS3 support change to "yes" -->
           Uncomment the lines below to get rid of jerky avi playback on the
           DSM320 or to enable subtitles support on the DSM units
          <add header="X-User-Agent: redsonic"/>
        <!-- Uncomment the line below if you have a Telegent TG100 -->
      <import hidden-files="no">
        <scripting script-charset="UTF-8">
          <virtual-layout type="builtin">
          <extension-mimetype ignore-unknown="no">
            <map from="flac" to="audio/x-flac"/>
            <map from="mp3" to="audio/mpeg"/>
            <map from="ogg" to="application/ogg"/>
            <map from="asf" to="video/x-ms-asf"/>
            <map from="asx" to="video/x-ms-asf"/>
            <map from="wma" to="audio/x-ms-wma"/>
            <map from="wax" to="audio/x-ms-wax"/>
            <map from="wmv" to="video/x-ms-wmv"/>
            <map from="wvx" to="video/x-ms-wvx"/>
            <map from="wm" to="video/x-ms-wm"/>
            <map from="wmx" to="video/x-ms-wmx"/>
            <map from="m3u" to="audio/x-mpegurl"/>
            <map from="pls" to="audio/x-scpls"/>
            <map from="flv" to="video/x-flv"/>
            <!-- Uncomment the line below for PS3 divx support -->
            <map from="avi" to="video/divx"/>
            <!-- Uncomment the line below for D-Link DSM / ZyXEL DMA-1000 -->
            <!-- <map from="avi" to="video/avi"/> -->
            <map from="audio/*" to="object.item.audioItem.musicTrack"/>
            <map from="video/*" to="object.item.videoItem"/>
            <map from="image/*" to="object.item.imageItem"/>
            <treat mimetype="audio/mpeg" as="mp3"/>
            <treat mimetype="application/ogg" as="ogg"/>
            <treat mimetype="audio/x-flac" as="flac"/>
            <treat mimetype="image/jpeg" as="jpg"/>
            <treat mimetype="audio/x-mpegurl" as="playlist"/>
            <treat mimetype="audio/x-scpls" as="playlist"/>
            <treat mimetype="audio/x-wav" as="pcm"/>
            <treat mimetype="audio/L16" as="pcm"/>
            <treat mimetype="video/x-msvideo" as="avi"/>
      <transcoding enabled="yes">
          <transcode mimetype="video/x-flv" using="vlcmpeg"/>
          <transcode mimetype="application/ogg" using="vlcmpeg"/>
          <transcode mimetype="application/ogg" using="oggflac2raw"/>
          <transcode mimetype="audio/x-flac" using="oggflac2raw"/>
          <profile name="audio-flac" enabled="no" type="external">
            <agent command="/opt/bin/flac" arguments="-dfs --force-raw-format --endian=big --sign=signed -o %out %i$
            <buffer size="1048576" chunk-size="131072" fill-size="262144"/>
          <profile name="oggflac2raw" enabled="yes" type="external">
            <agent command="/opt/bin/ogg123" arguments="-d raw -byteorder:big -f %out %in"/>
            <buffer size="1048576" chunk-size="131072" fill-size="262144"/>
          <profile name="vlcmpeg" enabled="no" type="external">
            <agent command="vlc" arguments="-I dummy %in --sout #transcode{venc=ffmpeg,vcodec=mp2v,vb=4096,fps=25,a$
            <buffer size="14400000" chunk-size="512000" fill-size="120000"/>
  • airflow

    airflow - 2010-11-26

    Mmh, your config looks basically the same like mine. My next guess would be permission problems, but as your PS3 starts playing the files, this can't be it neither. It would be interesting to know if the ogg123-process is crashing or exiting for some reason. I don't really know how to troubleshoot this further, perhaps you can add some additional logging-parameters to increase verbosity of this process. Have you ever tried to convert the FLAC-files you are testing with to some other format, like wav, to see if this succeeds?


  • lassel

    lassel - 2010-11-28

    The set up works with Windows Media Player (WMP).  What I mean is,,,, I can connect WMP to my MediaTomb server. If transcoding is enabled it is working nicely to play flac files. If transcoding is disabled,, WMP will not play.

    This must mean that transcoding is working,,, or ???  
    Somehow there is something in the data streamed from MediaTomb that are rejected by PS3 but accepter by WMP…


  • airflow

    airflow - 2010-11-29

    OK. This sounds strange to me, because the same config works in my setup. I also tested it with PS3 (newest firmware) together with mediatomb (newest SVN-checkout).

    What you could try out, though, is to use a different transcoding-application. If you check out this section in the mediatomb-wiki, you'll find that they use another application (ffmeg) for transcoding. Perhaps that changes anything:


  • Anonymous

    Anonymous - 2011-03-05

    I've used flac to transcode the output to PCM. As a bonus, if you're using the scrobbling, lastfmlib will still scrobble the details to your account.

          <profile name="audio-flac" enabled="yes" type="external">
            <agent command="flac" arguments="-dfs --force-raw-format --endian=big --sign=signed -o %out %in"/>
            <buffer size="1048576" chunk-size="131072" fill-size="262144"/>
  • ilke

    ilke - 2011-05-16

    I have identical issue as one described above by lglindstrom. But in my case I had flac transcoding working for few years until a month or two ago. Then suddenly PS3 has  started to skip between the files. I’m using flac to trancode but have ogg and ffmpeg profiles (turned off) that were tested and working before. I have 3.60 firmware and Ubuntu natty (same behavior was before I updated to natty).
    If I run ps3 media server or serviio they play flac no problems.

    lglindstrom any successes?


Log in to post a comment.