mebunto - 2011-03-31

Hi, I've successfully installed the mediatomb_0.12.1-0ubuntu1custom1_amd64 and it's working quite nicely.  My system is trying to upgrade related packages, such as xulrunner, to later versions, which in turn tries to "sidegrade" mediatomb to the current version that does not have javascript enabled …. two questions:

Do I need to ensure that the related packages (xulrunner etc) are not upgraded?
Is there another later mediatomb package that has javascript enabled which I should be using?

Thanks