classic question: transcoding avi to mpeg2

Help
2009-12-19
2013-05-30
  • Henrik Sekuj

    Henrik Sekuj - 2009-12-19

    I have a pc with debian lenny updated, with mediatomb0.12.0(I did updates to avoid mpeg 2  transoccoding problems).
    My objective is to play avi file with dreambox 500; it is well known that dreambox cannot play this format. It is not like ps3 too, which has divx support. Dm500s plays mpg,ts,vob, mp3 formats directly.
    I start mediatomb, make a djmount from stb, I can see the files in folder mounted as avi.m3u extension, and when selecting one of them the transcoding  with vlc starts, but the audio is faster with noises, and no pictureI appears the logo of mp3 player). May be that output is not correct, I make the configuration like for the ps3. A transcoding from avi to mpg may required, isn/t it ?
    I know that trasncoding with vlc in windows through a dreambox plugin called vlc frontend, works very well. But in this case, I am trying to play avi directly, so a complete transcoding may be needed.

    please anybody help me! Ihave several days working about it without success

    thanks in advance

     
  • Jin

    Jin - 2009-12-20

    I thought the dreambox has a UPnP client, do you really need to use djmount?

    Anyway, transcoding an avi to mpeg2 on the fly should not be a problem.

    I think the issue may be, that the dreambox thinks you are playing music and handles the media in a wrong way - because djmount foffers it inside an m3u playlist, instead of serving the file directly.

    Can you somehow tell djmount not to generate those playlists?

     
  • Henrik Sekuj

    Henrik Sekuj - 2009-12-20

    thank you for the help,

    I  thought the upnp client  is recenlty introduced in dm500 images, and images not erlier this summer like the sif that I use. I do not know any other method to use upnp functionality other than djmount. It is a problem in djmount of course. I put a recording from dm500 together with avi in the mediatomb folder. at begin, this recording was not appeared (.ts), then I added in config.xml a map to vieo/mpeg and then was appeared as .ts.mpg but it was unplayable!? In few words, from djmount is not playable, from nfs mount is playable(without use mediatomb too). I modify again config.xml, about ts extension, putting in external transcode by vlc. In this case it appears with .ts.m3u extension and it was the same behavior like avi's

    The ts file is played directly from dreambox normally. There two files in /var/bin: djmount, and djmount_script.sh, and one file in
    /var/lib/modules: fuse.ko.

    May be only djmount_script.sh editable

    it is only for starting and stoping or not

     
  • Jin

    Jin - 2009-12-20

    Well, you can try the following:

    rename your file to something.ts.mpg and see if it is still playable over NFS. If not - then we can assume that the dreambox player does not like multiple extensions in a file name.

    Regarding m3u stuff - that's obvious, djmount offers an m3u playlist with a link to the media, and I guess the dreambox assumes that m3u is audio only (which is actually correct).

    I guess in the end the only option will be to examine what djmount is doing and hack it… or get a new image with a UPnP client :)

     
  • Henrik Sekuj

    Henrik Sekuj - 2009-12-20

    Yes I tried as you said, it is suprising. Normally .ts files are played by dreambox, but not if extension is changed even in mpg. In few words, dm500 can play files with multiple extensions, but cannot play a .ts renamed in .mpg.
    The media types added for transcoding are added a .m3u, while video/mpeg types (in this way i configured ts) not provided for external transcoding, a .mpg is added
    i cannot play both types from dreambox from mediatomb

     
  • konrad O

    konrad O - 2011-01-08

    Hi,

    Have you managed transcoding on the fly with your dream box?
    Regards,
    K.

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks