Mediatomb and m2ts files

  • zombie woof

    zombie woof - 2012-09-24

    Could somebody help me?  I've been trying to add .m2ts to my Mediatomb database with no success. I've tried adding the following to the configuration file:

    <map from="m2ts" to="vidoe/mpeg"/>

    and stopped and started the service.  I've tried completely re-booting, tried using 'AVC' instead of mpeg and lots of other things many many times, but I still cannot get Mediatomb to recognize the m2ts files and add them to the database.

    Can anybody help me to get mediatomb to recognize these files?  Any help is gratefully received.

  • Jens

    Jens - 2012-09-24

    Did you copy that line from your Configuration File?

    Write video/mpeg istead of vidoe/mpeg :-)

    I've got the line <map from="m2ts" to="video/mpeg"/> and it still works

  • zombie woof

    zombie woof - 2012-09-25

    Hello Jens, unfortunately it was a typing error in my post. The entry in the config file is correct. But can I ask you; when you added the line, did you just restart the service or is there some other command to use?

    Any help is much appreciated.

  • Jens

    Jens - 2012-09-25

    I just restartet mediatomb.

    If you have set the entry ignore unknown could be possible to wait for next scan or to delete the Database and restart and rescan Media Directory (only if you dont see the file in your client)

    Second thing to try is if your client is able to play mpeg 4.

    If I remember right, mt2s is a container with mp-4 inside.

  • zombie woof

    zombie woof - 2012-09-25

    Thanks again for the feedback.  I will try to delete the database, but I don't understand why it doesn't just use the config file on re-start, the log file is telling me it's reading it. 

    Using the web management UI I can see the m2ts files in file mode, but it refuses to add them to the database!

  • Jens

    Jens - 2012-09-25

    Please let me and others know, if your Problem is solved then

  • zombie woof

    zombie woof - 2012-09-25

    It worked!  I wasn't expecting it to but it did.  Thanks very much.

    I stopped mediatomb, deleted 2 files:  mediatomb.db and mediatomb.db.backup.  Restarted, added 1 m2ts file via the web GUI and it was there in the database!

    I checked it on my LG Bluray player, which has a client, and it played smoothly just as it would with a SAMBA share.  (I tried it before with a different DLNA server, and that stuttered)

    Once again thanks very much for your suggestion.


Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks