SourceForge has been redesigned. Learn more.
Close

Video on DSM-520

Help
jocala
2007-03-31
2013-05-30
  • jocala

    jocala - 2007-03-31

    I've compiled mediatomb 0.9.0 under Kbuntu edgy eft and find that I can't play wmv files or mpeg/mpg files. When I select a wmv file the dsm-520 tells me it's unsupported and selecting a mpg/mpeg does nothing. These same files work fine with tversity or dlink's media server.  Playing divx/xvid files work fine. I haven't tested audio files yet.

     
    • Jin

      Jin - 2007-04-01

      Hi,

      I guess it may be related to the mimetype or something similar, probably the DSM-520 expects something special; I think we could figure this out rather easily, but I would need a wireshark/ethereal log.

      Could you please make two network captures?

      1. start t-versity, start dsm-520, browse to the video file that does not play on MT and press play.

      2. start mediatomb, start dsm-520, brows to the same video file and hit play.

      I think I will be able to see the difference in the browse replies and figure out the settings that you could use in MT in order to make it work.

      Please be patient if I do not reply fast, I am currently on holidays and only have a very slow GPRS connection :)

      Greetings,
      Jin

       
    • StephanV

      StephanV - 2007-09-24

      I've noticed a very similar issue on my DSM320 where no video file seems to be compatible, although I know the source files (AVI,MP4, etc...) are, as they have worked with order servers. 

      However, the weird part is that I have two MediaTomb 0.10.0 installs on two separate Ubuntu Feisty machines (some old 1GHz IBM box, and a VMware guest).  The IBM box gives me the same error message, but the same video works fine on the VMware guest.

      I don't think it's hardware-related, but rather probably software pollution-related.  On the IBM, I've evaluated many UPnP servers like GmediaServer, TwonkyVision and MediaTomb, and I might have also broken a codec or two, or not installed one correctly (sorry, I'm a bit of a noob here).  The VM has only had TwonkyVision and MediaTomb, and that install of MediaTomb is able to send out videos no problem (apart from an other problem I have with occasional choppy video, which is another problem altogether)

      Sorry, I'm a bit of a noob here, but if someone needs more info as to mime/types being reported by various servers, I'll gladly accept any direction as to how best to obtain these.

      If I could know a bit more where to look to yank the right stuff out to do a clean reinstall of MediaTomb on the IBM, I might be able to provide further details.

       
    • Jin

      Jin - 2007-09-24

      Check if the mimetype of those videos is set correctly, easiest thing to do that is: in the MT Web UI, find one of those "unsupported" items which you think should work, hit the "Edit" icon and look at the mimetype. If it's "application/octet-stream" then we found the problem. If it is something meaningful (like video/mpeg for MPEG, etc.) then we have to dig further...

       
      • StephanV

        StephanV - 2007-09-25

        Jin, thanks for the advice.

        I checked out a working AVI (wow! I found something that worked!), and its mimetype was video/x-msvideo.  Then I checked out an MP4 that used to work (under TwonkyMedia, but not in MediaTomb) and its mimetype was video/mp4 in the MT Web UI.

        I'm going to try to DSM-specific headers suggested in another post...  Only thing, I haven't seen where in the XML file they should be inserted?  (anywhere between <config> and </config> ?)  Maybe I just missed it -- I'll keep looking.

         
        • StephanV

          StephanV - 2007-09-25

          Sorry - no excuse for my ignorance, noob or not.   ;-)   I found the <server> section in config.xml, as documented!

           
      • StephanV

        StephanV - 2007-09-25

        Well the DSM-specific headers seem to have fixed my choppy video problem.  I was playing a video requiring over 2100kbps and it was playing quote smooth!  Maybe it's just a coincidence, but I'm pretty optimistic.

        On the other hand, MP4s still do not play.  I'm not sure what's up with that yey, but I'm still digging.

        Thanks for your help so far!

         
        • Jin

          Jin - 2007-09-25

          From what I remember the MP4 problem was not easy to solve, actually we were not able to solve it.

          Thats the tread about it, I think you did find it already:
          https://sourceforge.net/forum/forum.php?thread_id=1662799&forum_id=440750

          Somehow the D-Link server sends out different mimetypes for different requests when playing MP4 files, it's really weird and I have not yet figured out how to deal with this.

           
          • StephanV

            StephanV - 2007-09-25

            That would explain the wide variety of behavior I get from different MP4 files from different sources, whether they were Nero Recoded, or they were Video Podcasts from the web...  Hmm...  OK.  I may search for a decent MP4 to AVI transcoder then to suit me for the time being.

            Thanks!

             

Log in to post a comment.