GLIBC_2.3.4

Help
Konni
2005-06-18
2013-05-30
  • Konni

    Konni - 2005-06-18

    Hi there again :)
    Was trying to install the 0.8 release and I've been having some troubles, I've downloaded the mediatomb_0.8 rpm file and used "alien" to create a debian package.  Installed the package and everything went fine .. until then I'm trying to load up mediatomb i get "version GLIBC_2.3.4 not found",  this glibc release does not have an deb package yet so could you give me a little advise on what version i should d/l from gnu.org and what depencies i need, n.b. I was running version 0.71 without any troubles ...

    Thanks in advance,
    Konni.

     
    • x_gen

      x_gen - 2005-06-19

      I haven't played a lot with different binary packages and distros, but rather working directly with source code. so right now I can't give a competent answer to this.

      For now I would suggest that you try to build it from source code.

      Which debian and glibc version do you have? (and when did you do your last apt-get dist-upgrade ? :)

       
    • Konni

      Konni - 2005-06-19

      I'm running Ubuntu 5.04 (Debian 3.1),
      glibc version 2.3.2 which is the latest deb package availble for libc6.

      Otherwise my system is very up to date.
      Guess Ill build v. 2.3.4. from source.

       
    • Jin

      Jin - 2005-06-19

      Hi,

      the binary rpm package was compiled under Fedora Core 3, I have glibc-2.3.5 here.

      If I were you I would rather rebuild mediatomb and not touch glibc...

      I now have a debian notebook, so I will take a look at the .deb stuff and hopefully come up with some debian packages for the next release.

       
    • Konni

      Konni - 2005-06-20

      Any change that you could make a deb package for release 0.8 ?

       
      • x_gen

        x_gen - 2005-06-20

        Currently there are some issues with binary packages in both rpm and deb format. We'll need to check how to do it the RIGHT way.

        The problem is that mediatomb version 0.8.1 (which is almost ready to be released at least in tar.gz flavor) optionally depends on packages some of which are not part of debian or fedora distributions. Those are
        - libexiv2 - not present in both debian and fedora
        - libjs - present in debian as libsmjs, but not present
                  in fedora.

        We definitely don't want to have the sources of any dependant libraries to be included into the mediatomb source tree.
        Maybe I am overcomplicating this, but nevertheless we need to investigate, how can one build a package for debian or fedora based on a library NOT present in the distribution.

        Any Ideas would be appreciated by the way ...

        In fact I'm not a big fan of binary packages.
        I have never done a .deb package before, but I'll definitely build one. Actually I am a die hard debian user, and it's a shame that I don't know how to create a deb package, eager to learn how it works :)

        A deb will definitely appear for one of the next releases,
        once I find a correct way to handle the problem described above.

         
        • Konni

          Konni - 2005-06-20

          Great to hear.
          Thank you for that.

          Looking forward then for release 0.81

           

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks