Won't run

  • Damon

    Damon - 2010-12-21

    I have installed Media Tomb on my Ubuntu 10.04 LTS server and when I try to run it freezes after showing the http link to go to and I have to hit Ctrl + C to get a new command line and when I try to go to that link it doesn't work. I am new to this and am not sure why this is happening. I have tried using sqlite and mysql with it but neither work. Any ideas?

  • mianbao

    mianbao - 2010-12-21

    Hey coomikaze, it might actually be working fine.  Mediatomb runs in the foreground of the shell you run it in, which means it will look like it is frozen after it shows the http link.  If you don't like this, you can run it with an & after the command to force it to run in the background, like so:

    sudo mediatomb &

    So the bigger problem is when you go to that link, it doesn't work.  Is it just a broken link when you go to it?  Or a log in screen?  What do you get?


  • Damon

    Damon - 2011-01-05

    Sorry for the delayed response. Thanks for the advice about adding & thats what is was. The link is still not opening though. I get the "The connection has timed out." message. It seems to start up just fine on the server. I am using Firefox and entering in the link exactly as I should. What could the issue be?

  • mianbao

    mianbao - 2011-01-13

    Hey again.  So you're trying to follow the link right on the same server?  Or somewhere else on the network?  If it's somewhere else on the network, perhaps you need to open up ports on the network (honestly I'm not sure how to do that, though…it might need to be done on your router or on the server itself or both). 

    If you can't open the link right on the same machine that is running mediatomb that's pretty weird.  Also, it's interesting that it's telling you that the connection has timed out, rather than it couldn't find it.  So that indicates to me that mediatomb is running but  Firefox can't get to it, which points to a ports issue.

    Try going through this list:

    Good luck!


  • Damon

    Damon - 2011-01-22

    Mediatomb is running on my Linux server that doesn't have a GUI and I am trying to open the link on my Windows desktop. They are both connected to the same Linksys router and I don't see anything in the router settings that would block the port. Also now it won't even run, it says my sqlite3 database is locked and I am not sure how to unlock it. Seems as though I will need to fix that first before trying to get the link working.

  • Giulio Martinat

    Giulio Martinat - 2011-01-22

    You usually get that error when trying to access the SQLite database with two distinct applications. The fastest way to fix that is making sure no other instance of mediatomb is running on the server (ps -ef |grep mediatomb at a terminal should take care of that). As a last resort, delete the database and start over

  • Damon

    Damon - 2011-01-27

    Ok, it isn't locked anymore and seems to run just fine but I can't open the link on my desktop. I have enable port forwarding for port 1900 on my router and entered "sudo iptables -A INPUT -p tcp -d 0/0 -s 0/0 -dport 1900 -j ACCEPT" to open the port but still the like won't open and I have absolutely no idea why. I am open to almost anything at this point. PLEASE HELP!

  • Damon

    Damon - 2011-01-27

    Also, can see mediatomb on my PS3, so its not showing anywhere. Though this was supposed to be an easy media server but it is a nightmare.

  • Damon

    Damon - 2011-01-27

    Sorry I meant can't see mediatomb on my PS3.

  • mianbao

    mianbao - 2011-01-27

    Hey coomikaze, sorry you're having trouble.  I would suggest sticking with it a bit longer as once you have it up and running it's a really flexible and reasonably solid media server.  Also, I originally replied because I'm running it on Ubuntu 10.04 and I'm using a PS3 as a client.  Anyway, I have a couple of more things to try:

    So I know your server doesn't have a GUI display, but what do you think of hooking up a monitor to it?  Does it have a video card or onboard video?  Seeing if the link is broken from the server itself would help to narrow the problem down.

    This is a lame suggestion, probably, but when I first did my install I horked the database somehow because I didn't know what I was doing with the GUI.  I struggled with it for a while and then just ended up uninstalling it and reinstalling it through the ubuntu software manager.  BAM!  It came back up and worked like a charm immediately.  It's not super-satisfying from a mystery solving perspective, but it was such a quick fix for me I thought I'd send it along.

    If that doesn't work, I'd be pretty tempted to try PS3 Media Server:

    I'm actually running that alongside my mediatomb instance, and I prefer mediatomb, but I got PS3MS up and running faster.

    Ooh!  One other thought, though a long-shot.  If you are running a VPN on your windows box, that might kill the mediatomb link even if they are on the same network.

    Good luck, and I hope you are streaming whatever you plan to soon. 



Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks