Foreign characters in file and folder names

  • Joshua Calvert

    Joshua Calvert - 2011-12-11

    Hello! I m from sweden and I m trying to get Mediatomb to display language proper characters for file and folder names. In the webui as well as XBMC folders or filenames containing my native characters gets mucked up and I ve been trying to rememdy this by changing config-xml by adding


    I ll snip out the section of the config.xml where I m adding this:

    Prior to my change

      <import hidden-files="no">
        <scripting script-charset="UTF-8">

    After my change:

      <import hidden-files="no">
        <scripting script-charset="ISO-8859-15">

    Is this properly inserted to make Mediatomb use my native lettering Å å Ä ä Ö ö?

    I ll also provide a screenshot of what it looks like browsing the Filsesystem when it s displaying files with my native lettering:

    I have restarted the serer after making changes. I also read somewhere that Mediatomb overrides charmap settings if Locale is set in OS. My locale was US/ENG when I installed Mediatomb. I then changed locale of my OS (Lucid 10.04) to my native locale, which now reports like so:

    jango@Mediaserver:~$ locale

    I would really apprecite if someone could hold my hand and guide me through this mess. On top of this, I m a linux n00b so dont assume I know anything.

    Thanks in advance for any suggestions that could help get this train back on the tracks.

  • Joshua Calvert

    Joshua Calvert - 2011-12-11

    I forgot to mention that I have also deleted the .db files and restarted the server to try to make Mediatomb recreate the .db's with the new characterencoding. The above screenshot was made after I have tried all these changes. Apparantly to no avail.

  • Joshua Calvert

    Joshua Calvert - 2011-12-12

    Ohoy! I Seem to have solved the issue simply by trial and error.

    What I did was I added the lines to config.xml as stated above but instead of using the ISO-8859-1 encoding I entered UTF-8 in all tags, liks so:

    </server> <import hidden-files="no"> <filesystem-charset>UTF-8</filesystem-charset> <metadata-charset>UTF-8</metadata-charset> <scripting script-charset="UTF-8">

    Dont have a clue of the changing of 'Locale' to my native language was a contributing factor, but if it doesnt work with only adding UTF-8 to all tags as stated above and your locale is set to anything else than your native one, maybe you should force a locale change or reinstall your OS with your proper locale settings from scratch.


  • Ufuk Ulusoy

    Ufuk Ulusoy - 2011-12-17

    Really worked man! Thanks to you….


Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.

No, thanks