SRT subtitles for Samsung TV's w/o Transcode

1 2 3 > >> (Page 1 of 3)
  • Nithin Philips

    Nithin Philips - 2010-12-05

      I have a Samsung LN46C630 TV with DLNA support and I've been using mediatomb as my DLNA server. The setup works almost perfectly. The problem I'm experiencing is that the TV cannot show .SRT subtitles embedded in MKV files. However, the TV is able to display an SRT attached as a DLNA res. I tried adding a transcoding profile that presented an "smi/caption" format along with the video, but unfortunately, the TV using a proprietary extension (sec:CaptionInfoEx) to point to the SRT file.

    Here's the content data sent by Samsung PC Share Manager program:
    (captured by someone at

    <DIDL-Lite xmlns="urn:schemas-upnp-org:metadata-1-0/DIDL-Lite/" xmlns:dc="" xmlns:upnp=&apos;urn:schemas-upnp-org:metadata-1-0/upnp/&apos; xmlns:dlna="urn:schemas-dlna-org:metadata-1-0/"
    xmlns:sec=""><item id="V_D_0000_9_376" parentID="V_D_0000_9" restricted="1">
    <sec:dcmInfo>CREATIONDATE=1253629219,FOLDER=01 - Sous-Titrés</sec:dcmInfo>
    <sec:CaptionInfoEx sec:type="srt"></sec:CaptionInfoEx>
    <res protocolInfo="http-get:*:video/x-msvideo:DLNA.ORG_OP=01;DLNA.ORG_CI=0;DLNA.ORG_FLAGS=01500000000000000000000000000000" size="733958196" duration="1:25:25"></res>
    <res protocolInfo="http-get:*:image/jpeg:DLNA.ORG_PN=JPEG_SM;DLNA.ORG_CI=1;DLNA.ORG_FLAGS=00D00000000000000000000000000000"></res>
    <res protocolInfo="http-get:*:image/jpeg:DLNA.ORG_PN=JPEG_TN;DLNA.ORG_CI=1;DLNA.ORG_FLAGS=00D00000000000000000000000000000"></res>

    I can write a patch myself, but where should I add the code to attach "<sec:CaptionInfoEx sec:type="srt">…</sec:CaptionInfoEx>" to the XML data sent to the TV by mediatomb. Appreciate any guidance, help, suggestions etc. Thanks.

  • Jin

    Jin - 2010-12-20

    Have a look at the UpnpXML_DIDLRenderObject function in UPnP XML, it should go there, just take resource 0 from the object (add your changes after CdsResourceManager::addResources(item, result)  ) and append .srt at the end of the URL; make sure that your .srt file is named the same as the video, just with .srt extension instead of .avi (or whatever the original extension was), put it in the same directory on disk. This should be it.

  • William Grzybowski


    @spikiermonkey, have you been hable to make that patch? I am also really interested.
    I would try that myself but my skills with xml and c++ and very limited.

    Thank you

  • Athanasios Matsoukas

    I 've been searching for this upgrade quite a long time now.. since i have mediatomb working like a charm on my WD WE II whitelight except the subtitles feature which is missing. I am more than anxious to test it :DDD Keep up the good work

  • Athanasios Matsoukas

    As I have seen a couple of days ago in the post you have allready provided there was a result.


    It seems that they have achived that feature on ps3 Media Server. Maybe this can help in the patching of media tomb :D

  • Nithin Philips

    Nithin Philips - 2011-02-24


    The patch by Marcin that amats mentioned works beautifully.

    For those of you using Ubuntu, binaries built from the svn source will segfault when you initialize playback, so here' how I built working mediatomb binaries with the patch:

    First, there are quite a few dependencies, lists most of them that are available as ubuntu packages. Install them.

    Second, there are a few debian specific patches that need to be applied. For that, download the *.debian.tar.gz file from launchpad: . I used the one for Lucid: , try to get the one for your release.

    Extract the tarball and you'll find the patches in the 'debian/patches' directory. The paths in these patches need to edited before applying:

    Use sed to edit the files:

    cd debian/patches
    sed -i "s/ a\// /g" *.patch
    sed -i "s/ b\// /g" *.patch

    cd to the mediatomb source directory and do

    autoreconf -i

    Then apply the patchs:

    patch -p0 -i <path-to-patch>

    And finally, apply the samsung patch (assuming it is in your home dir):

    patch -p0 -i ~/samsung_video_subtitles.patch

    Now we can build and install:

    make && sudo make install

    If nothing goes wrong, you show now be able to run mediatomb with subtitle support.

    Also, a few notes on the config file: You need to set the samsung-hacks attribute and the paths might be different from the ubuntu package installs. My working config.xml is at: You can use that as a reference.

    Hope this helps.

  • Nithin Philips

    Nithin Philips - 2011-02-24

    ED: Please disregard all that stuff about debian patches. Most of them have been already integrated into svn. My segfault was caused by a missing element in the config. I filed a bug at:

    Meanwhile, If anyone's using the config.xml that I posted, edit the mark-played-items element so that it looks like this:

    <mark-played-items enabled="yes" suppress-cds-updates="yes">
    <string mode="prepend">*</string>


    I wasn't able to narrow down the problem till later. Sorry about any trouble.

  • Athanasios Matsoukas

    Greetings everyone,

    I am glad I have contributed in the cause adding subtitles in mediatomb. Allthought I am not a linux familiar I have tried so many times to make an optware version of mediatomb but all of them where unsuccessfull. I want to use it on a WD whitelight 2GB ethernet HD so that i can download all my movies there and play them on demand from any DLNA device in my network.

    I'm very dissapointed and I would really appreciete if someone could make a build for optware with those patches applied.

    In any case thank you for reading my post.

    best regards,

  • Nithin Philips

    Nithin Philips - 2011-05-21

    Have you tried following this guide: <>?

    If the compilation still fails, if you can post any error messages (either here or on pastebin), I might be able to help you track down the problem.

  • Athanasios Matsoukas

    Greetings, I have tried to follow the instructions in the site given. As with all my attempts when it comes to ./configure a bunch of errors appear.

    ~ # wget
               => `libiconv-1.13.1.tar.gz'
    Connecting to||:80… connected.
    HTTP request sent, awaiting response… 200 OK
    Length: 4,716,070 (4.5M)

    100% 4,716,070    340.42K/s    ETA 00:00

    21:57:04 (239.06 KB/s) - `libiconv-1.13.1.tar.gz' saved

    ~ # gzip -cd libiconv-1.13.1.tar.gz | tar -xf -
    ~ # ls
    libiconv-1.13.1         libiconv-1.13.1.tar.gz
    ~ # cd libiconv-1.13.1
    ~/libiconv-1.13.1 # ./configure
    as_echo: eval: 1: tr: not found
    build-aux/install-sh -c
    as_echo: eval: 1: tr: not found
    as_echo: eval: 1: tr: not found
    build-aux/install-sh -c -d
    as_echo: eval: 1: tr: not found
    as_echo: eval: 1: tr: not found
    as_echo: eval: 1: tr: not found
    as_echo: eval: 1: tr: not found
    as_echo: eval: 1: tr: not found
    as_echo: eval: 1: tr: not found
    as_echo: eval: 1: tr: not found
    as_echo: eval: 1: tr: not found
    as_echo: eval: 1: tr: not found
    as_echo: eval: 1: tr: not found
    configure: error: in `/root/libiconv-1.13.1':
    configure: error: no acceptable C compiler found in $PATH
    See `config.log' for more details.
    ./configure: ./configure: 1: sort: not found
    ./configure: ./configure: 91: sort: not found
    ~/libiconv-1.13.1 #

    This happend to all linux versions i tried to compile mediatomb following instructions. I don't know what i am doing wrong. but now i have it also on my WD World Edition II Whitelight 2TB.

    Any help would be appreciated.

    thanks in advance

  • Nithin Philips

    Nithin Philips - 2011-05-21



    command is part of the GNU CoreUtils and that package appears to be missing (may be normal on that device.) It also seems to be missing gcc or another compiler. I did some further research and it appears that the trouble to get mediatomb to compile on the device may not be worth it.

    Another, easier, option is probably to use the optware system to cross-compile on a PC and then install using the ipkg tool. I am trying to compile mediatomb this way on Ubuntu Natty release, but having some trouble getting a required package, libjs. The ftp site seems to be down. I'll keep trying and will let you know how it turns out.

    There is cross-compile guide at < >

    Meanwhile, If you'd like to give it a try yourself, you can install Natty on a virtual machine and then you'll need the





    Do steps 1 and 2 from be guide above, then:

    To get the latest source from subversion, you'll need to edit the


    file and uncomment the following lines:


    Then change the


    value to


    . It should now be:


    Now, perform step 3 from the guide, with


    If everything goes well, you should have an ipkg package. The guide at < > shows how to install it.

    • Remember, this won't have the samsung subtitle patch applied and that'll have to be integrated into the build process, but once you can get mediatomb to cross-compile integrating the patch should be easy.

    Further information about making optware packages can found at < >.

  • Athanasios Matsoukas

    Greetings again,

    that was promising enought and i got really close to the so wanted "make" but as soon as i did

    make ${package} -unpack

    I followed your instuctions applying the patch like follows

    amats@ubuntu:~/optware/sources/mediatomb$ patch -p0 -i ~/samsung_video_subtitles.patch
    patching file src/
    Hunk #1 FAILED at 1433.
    1 out of 1 hunk FAILED -- saving rejects to file src/
    patching file src/common.h
    Hunk #1 FAILED at 196.
    Hunk #2 FAILED at 243.
    2 out of 2 hunks FAILED -- saving rejects to file src/common.h.rej
    patching file src/config_manager.h
    Hunk #1 FAILED at 73.
    1 out of 1 hunk FAILED -- saving rejects to file src/config_manager.h.rej
    patching file src/
    Hunk #1 FAILED at 482.
    1 out of 1 hunk FAILED -- saving rejects to file src/
    patching file src/
    Hunk #1 FAILED at 305.
    1 out of 1 hunk FAILED -- saving rejects to file src/
    patching file src/
    Hunk #1 FAILED at 106.
    1 out of 1 hunk FAILED -- saving rejects to file src/
    patching file src/
    Hunk #1 FAILED at 381.
    1 out of 1 hunk FAILED -- saving rejects to file src/
    patching file src/upnp_xml.h
    Hunk #1 FAILED at 76.
    1 out of 1 hunk FAILED -- saving rejects to file src/upnp_xml.h.rej

    I don't know what have i done wrong this time.

  • Athanasios Matsoukas

    I tried again fallowing all the steps one by one from the begining with all required files downloaded locally. No mistakes in the build process and finaly at the end this popups again.

    if test -n "/home/amats/optware/cs05q1armel/sources/mediatomb/mediatomb_nas.patch" ; \
            then cat /home/amats/optware/cs05q1armel/sources/mediatomb/mediatomb_nas.patch | \
            patch -d /home/amats/optware/cs05q1armel/builds/mediatomb-0.11.0 -p1 ; \
    patching file
    Hunk #1 FAILED at 24.
    Hunk #2 FAILED at 471.
    Hunk #3 FAILED at 1224.
    Hunk #4 FAILED at 1943.
    Hunk #5 FAILED at 2919.
    5 out of 5 hunks FAILED -- saving rejects to file
    patching file src/
    Hunk #1 FAILED at 24.
    Hunk #2 FAILED at 385.
    Hunk #3 FAILED at 889.
    3 out of 3 hunks FAILED -- saving rejects to file src/
    make: *** [/home/amats/optware/cs05q1armel/builds/mediatomb/.configured] Error 1

    I do not understand what am I doing wrong in this process. Any tip will be very much appreciated.

  • Nithin Philips

    Nithin Philips - 2011-05-23

    The patch is failing because
    1) the mediatomb source directory structure does not match the expected one, and
    2) the patch files do not follow the optware conventions.

    To fix this, first, you'll need to edit and change the line:




    then delete ~/optware/cs05q1armel/downloads/mediatomb-x.xx.tar.gzip, so that the mediatomb source will be downloaded again.

    But the mediatomb_nas patch appears to be already integrated into the mediatomb svn, so it is not necessary. To apply the Samsung subtitle patch instead, as part of the build process, edit the file and change line 58 to:


    and the place the file samsung_video_subtitles.patch in the ~/optware/sources/mediatomb directory.

    Then, to change the patch file so that the optware automatic configuration target can handle it, you'll have to edit the samsung_video_subtitles.patch. Using sed, the following commands should do the job:

    $ cd ~/optware/sources/mediatomb
    $ mv samsung_video_subtitles.patch samsung_video_subtitles.patch.bak
    $ cat samsung_video_subtitles.patch.bak | sed -e "s_src/_/src/_g" > samsung_video_subtitles.patch

    Finally run, make ${package}-unpack again, followed by make ${package} _and _make ${package}-ipk.

    I had to disable javascript support for the build process to work, but YMMV. At the end you should have a mediatomb_xxx_arm.ipk file in ~/optware/cs05q1armel/builds directory.

  • Athanasios Matsoukas

    I have tried yesterday all evening to make this work but unfortunatelly the same again.

    I followed all your tips and used them in all of my attempts. But when the time came for the patch to apply, Hunk # Failed for all lines.

    I cleared the build between all steps and compiled it again several times with different approaches.

    1) I made a build  for 0.11.0 successfully without the patch applied and installed it on WD

    2) I got in ~/optware/cs05q1armel/builds/mediatomb-0.11.0 after ${package}-unpack and  applied the patch manually which worked without any errors but didn't know what to do next.

    3) I tried also to use autoreconf -i and ./configure and worked normal

    3) I even made a build for 0.12.1 successfully and install it also on WD

    I think i mixed up everything at the end testing all combinations together. I really don't understand what is the problem. Could it be the patch? Do i need something more specific -I don't know- a lib maybe, or something is missing, or another revision for mediatomb?

    Anyway thanks a million for all your help

  • Athanasios Matsoukas

    my bad… i missed that

    $ cd ~/optware/sources/mediatomb 
    $ mv samsung_video_subtitles.patch samsung_video_subtitles.patch.bak 
    $ cat samsung_video_subtitles.patch.bak | sed -e "s_src/_/src/_g" > samsung_video_subtitles.patch

    I'll try it as soon as i get home and let you know. Thanks for all the help provided and patience

  • Athanasios Matsoukas

    spikiermonkey thanks a million !!!!

    I have used "sed" in both patches and applied them both just to be sure..

    The build / installation / running process worked like a charm.

    best regards,

  • Greg

    Greg - 2011-05-28

    Hi Amats, Could you provide your config.xml and ./configure result ? I have tried with SVN trunk and 0.12 version and my Samsung TV (LE37C630) still does not recognize subtitles in movies.

  • Greg

    Greg - 2011-05-29

    Just to update. I tried again and it really works fine now. I converted my *.txt (MicroDVD) subtitles to .srt format and now it's OK.
    The question is: Could someone modify patch for txt subtitles format compatibility?
    May I use transcoding functionality in order to convert txt2srt format?

  • Cem

    Cem - 2011-07-04

    Hello everyone.

    Amats or somebody else, can you guys please upload your " mediatomb_xxx_arm.ipk file " and config file so that other Optware / NAS users may use it with their samsung TVs?

    I cannot build anything at command level, I think using the ipk file I can install mediatomb easily without the difficult building part.

  • Nithin Philips

    Nithin Philips - 2011-07-06

    For anyone trying to build the ipk yourself, the following additional information might be useful:

       1) The prebuilt arm gcc compiler used by optware is 32-bit. You need a 32-bit OS or 32-bit libs. YMMV on 64-bit OS.
       2) You can find libjs source at The ftp used by optware build system appears to be gone. So, save 'js-1.6.20070208.tar.gz' to ~/optware/downloads directory and then run  make ${package}-unpack (in the ~/optware/${platform} directory).

    Here's the build for WD Whitelight device (with js support):

    I don't have any WD devices, so this hasn't been tested.

  • Nick

    Nick - 2011-07-25

    Hi I am running Debian and have a Samsung 7 LED LCD TV, and running Mediatomb on it (just updated to latest version today).

    I cannot get .srt files to be recognized by the TV. I have tried Serviio DLNA server and that works just fine - BUT I wish to use Mediatomb since I like this server better. But it has to be able to support srt files.

    I am not talking about embedded subtitles in mkv files, but .srt files that are named identical to the video file (except the file ending that is).

    How can I proceed to get the srt files to be recognized by the Samsung TV?


  • Nithin Philips

    Nithin Philips - 2011-07-26

    To get Samsung TV subtitle support, you need to compile mediatomb from source with subtitle patch.

    You can get detailed steps, dependencies etc from this post:

    Here's the abridged version:

    Get mediatomb source from subversion:

    svn co mediatomb

    Then generate the configure script by running autotools:

    cd mediatomb
    autoreconf -i

    Then, you can get the patch file from Marcin's post:

    While in the mediatomb directory, run the following command to apply the patch:

    patch -p0 -i <path-to-patch>

    If there are no errors, you can configure the project and build it:

    make && sudo make install

    Finally, edit the config.xml file to enable the Samsung subtitle support (see the comments in Marcin's post for more info):

    <protocolInfo extend="yes" samsung-hack="yes"/>
  • Nick

    Nick - 2011-07-26


    I have tried the following exactly now:

    svn co mediatomb
    autoreconf -i
    patch -p0 -i <path-to-patch>

    So far so good… But when I try to do the ./configure inside the directory, I get the following errors:

    configure: error: Support of at least one of mysql or sqlite3 must be configured

    Below is the complete output from the ./configure:

    root@b3:/home/nick/downloads/mediatomb/mediatomb# ./configure
    checking for a BSD-compatible install… /usr/bin/install -c
    checking whether build environment is sane… yes
    checking for a thread-safe mkdir -p… /bin/mkdir -p
    checking for gawk… gawk
    checking whether make sets $(MAKE)… yes
    checking build system type… armv5tel-unknown-linux-gnueabi
    checking host system type… armv5tel-unknown-linux-gnueabi
    checking for g++… g++
    checking whether the C++ compiler works… yes
    checking for C++ compiler default output file name… a.out
    checking for suffix of executables…
    checking whether we are cross compiling… no
    checking for suffix of object files… o
    checking whether we are using the GNU C++ compiler… yes
    checking whether g++ accepts -g… yes
    checking for style of include used by make… GNU
    checking dependency style of g++… gcc3
    checking for gcc… gcc
    checking whether we are using the GNU C compiler… yes
    checking whether gcc accepts -g… yes
    checking for gcc option to accept ISO C89… none needed
    checking dependency style of gcc… gcc3
    checking for ranlib… ranlib
    checking how to run the C preprocessor… gcc -E
    checking for grep that handles long lines and -e… /bin/grep
    checking for egrep… /bin/grep -E
    checking whether gcc needs -traditional… no
    checking for dirent.h that defines DIR… yes
    checking for library containing opendir… none required
    checking for ANSI C header files… yes
    checking for sys/wait.h that is POSIX.1 compatible… yes
    checking for sys/types.h… yes
    checking for sys/stat.h… yes
    checking for stdlib.h… yes
    checking for string.h… yes
    checking for memory.h… yes
    checking for strings.h… yes
    checking for inttypes.h… yes
    checking for stdint.h… yes
    checking for unistd.h… yes
    checking for stdbool.h that conforms to C99… yes
    checking for _Bool… yes
    checking whether time.h and sys/time.h may both be included… yes
    checking whether stat file-mode macros are broken… no
    checking whether gcc and cc understand -c and -o together… yes
    checking time.h usability… yes
    checking time.h presence… yes
    checking for time.h… yes
    checking syslog.h usability… yes
    checking syslog.h presence… yes
    checking for syslog.h… yes
    checking stddef.h usability… yes
    checking stddef.h presence… yes
    checking for stddef.h… yes
    checking for unistd.h… (cached) yes
    checking arpa/inet.h usability… yes
    checking arpa/inet.h presence… yes
    checking for arpa/inet.h… yes
    checking fcntl.h usability… yes
    checking fcntl.h presence… yes
    checking for fcntl.h… yes
    checking limits.h usability… yes
    checking limits.h presence… yes
    checking for limits.h… yes
    checking netdb.h usability… yes
    checking netdb.h presence… yes
    checking for netdb.h… yes
    checking netinet/in.h usability… yes
    checking netinet/in.h presence… yes
    checking for netinet/in.h… yes
    checking for stdlib.h… (cached) yes
    checking for string.h… (cached) yes
    checking sys/file.h usability… yes
    checking sys/file.h presence… yes
    checking for sys/file.h… yes
    checking sys/ioctl.h usability… yes
    checking sys/ioctl.h presence… yes
    checking for sys/ioctl.h… yes
    checking sys/socket.h usability… yes
    checking sys/socket.h presence… yes
    checking for sys/socket.h… yes
    checking sys/time.h usability… yes
    checking sys/time.h presence… yes
    checking for sys/time.h… yes
    checking for sys/types.h… (cached) yes
    checking for sys/wait.h… (cached) yes
    checking langinfo.h usability… yes
    checking langinfo.h presence… yes
    checking for langinfo.h… yes
    checking locale.h usability… yes
    checking locale.h presence… yes
    checking for locale.h… yes
    checking sys/utsname.h usability… yes
    checking sys/utsname.h presence… yes
    checking for sys/utsname.h… yes
    checking sched.h usability… yes
    checking sched.h presence… yes
    checking for sched.h… yes
    checking ctype.h usability… yes
    checking ctype.h presence… yes
    checking for ctype.h… yes
    checking for sched_getparam… yes
    checking for sched_setparam… yes
    checking for sched_get_priority_min… yes
    checking for sched_get_priority_max… yes
    checking for mkdir… yes
    checking getopt.h usability… yes
    checking getopt.h presence… yes
    checking for getopt.h… yes
    checking for getopt_long… yes
    checking for mkfifo… yes
    checking iconv.h usability… yes
    checking iconv.h presence… yes
    checking for iconv.h… yes
    checking for iconv… yes
    checking if iconv declaration requires const char cast… no
    checking execinfo.h usability… yes
    checking execinfo.h presence… yes
    checking for execinfo.h… yes
    checking for time_t… yes
    checking for special C compiler options needed for large files… no
    checking for _FILE_OFFSET_BITS value needed for large files… 64
    checking for off_t… yes
    checking for size_t… yes
    checking for _LARGEFILE_SOURCE value needed for large files… no
    checking size of off_t… 8
    checking size of size_t… 4
    checking size of time_t… 4
    checking size of unsigned int… 4
    checking size of unsigned long… 4
    checking for strtoll… yes
    checking for nl_langinfo… yes
    checking for setlocale… yes
    checking for backtrace… yes
    checking for backtrace_symbols… yes
    checking for an ANSI C-conforming const… yes
    checking for inline… inline
    checking for working volatile… yes
    checking return type of signal handlers… void
    checking for pid_t… yes
    checking for size_t… (cached) yes
    checking for int64_t… yes
    checking for ssize_t… yes
    checking for uint32_t… yes
    checking whether struct tm is in sys/time.h or time.h… time.h
    checking whether byte ordering is bigendian… no
    checking whether LONG_MAX is declared… yes
    checking whether LLONG_MAX is declared… yes
    checking for working alloca.h… yes
    checking for alloca… yes
    checking whether closedir returns void… no
    checking for error_at_line… yes
    checking vfork.h usability… no
    checking vfork.h presence… no
    checking for vfork.h… no
    checking for fork… yes
    checking for vfork… yes
    checking for working fork… yes
    checking for working vfork… (cached) yes
    checking for stdlib.h… (cached) yes
    checking for GNU libc compatible malloc… yes
    checking for working memcmp… yes
    checking for stdlib.h… (cached) yes
    checking for GNU libc compatible realloc… yes
    checking sys/select.h usability… yes
    checking sys/select.h presence… yes
    checking for sys/select.h… yes
    checking for sys/socket.h… (cached) yes
    checking types of arguments for select… int,fd_set *,struct timeval *
    checking whether lstat correctly handles trailing slash… yes
    checking whether stat accepts an empty string… no
    checking for working strtod… yes
    checking for vprintf… yes
    checking for _doprnt… no
    checking whether strerror_r is declared… yes
    checking for strerror_r… yes
    checking whether strerror_r returns char *… no
    checking for strftime… yes
    checking for gethostname… yes
    checking for gettimeofday… yes
    checking for localtime_r… yes
    checking for memmove… yes
    checking for memset… yes
    checking for regcomp… yes
    checking for select… yes
    checking for strcasecmp… yes
    checking for strchr… yes
    checking for strdup… yes
    checking for strerror… yes
    checking for strncasecmp… yes
    checking for strrchr… yes
    checking for strstr… yes
    checking for strtol… yes
    checking for strtoul… yes
    checking for uname… yes
    checking for sigaction… yes
    checking for sigprocmask… yes
    checking for ioctl… yes
    checking for tolower… yes
    checking for toupper… yes
    checking for inet_ntoa… yes
    checking for socket… yes
    checking for gethostbyname… yes
    checking how to run the C++ preprocessor… g++ -E
    checking for gethostbyname_r… yes
    checking for if_nameindex… yes
    checking for if_freenameindex… yes
    checking for the pthreads library -lpthreads… no
    checking whether pthreads work without any flags… no
    checking whether pthreads work with -Kthread… no
    checking whether pthreads work with -kthread… no
    checking for the pthreads library -llthread… no
    checking whether pthreads work with -pthread… yes
    checking for joinable pthread attribute… PTHREAD_CREATE_JOINABLE
    checking if more special flags are required for pthreads… no
    checking for clock_gettime in -lrt… yes
    checking zlib.h usability… yes
    checking zlib.h presence… yes
    checking for zlib.h… yes
    checking for uncompress in -lz… yes
    checking sqlite3.h usability… no
    checking sqlite3.h presence… no
    checking for sqlite3.h… no
    checking /usr/local/include/sqlite3.h usability… no
    checking /usr/local/include/sqlite3.h presence… no
    checking for /usr/local/include/sqlite3.h… no
    checking for mysql_config… none
    checking for mysql_config… none
    mysql_config not found, please install the mysql devel package
    configure: none could not be executed or returned invalid values
    configure: error: Support of at least one of mysql or sqlite3 must be configured

    Please help me on how to proceed.

1 2 3 > >> (Page 1 of 3)

Log in to post a comment.