libjs 1.8.5 segfault

Help
2011-10-23
2013-05-30
  • Lester Caine

    Lester Caine - 2011-10-23

    I'm on SUSE 11.3 and 4 and have had mediatomb running nicely on bother severs, but I had a shout from SWMBO saying that she could not see the films list on the TV and when I checked the media server (11.4 machine), mediatomb was segfaulting on libjs.1.8.5 … After a long process of elimination, I finally found that dropping back to 1.8.0 restored operation again. Not sure quite when this update was applied, but the same fault was happening on 11.3, and the same fix restored operation again. Is this a new bug or am I missing something?

     
  • alex sayle

    alex sayle - 2011-10-25

    what you're missing is that mediatomb 1.2.1 doesn't support libmozjs 1.8.5  the API is different and its a minor change to the code.

    I've ported mediatomb to use libmozjs 1.8.5 as part of my attempt to add python support to mediatomb. if you're keen you can look in the open discusssion section and find the code on my git hub account. 

     

Log in to post a comment.