libjs

Help
paul
2005-07-22
2013-05-30
  • paul

    paul - 2005-07-22

    Hi,
    Im trying to install mediatomb and i got errors about a bunch of dependencies which i managed  to find and install but the only one i cannot find is libjs all the versions ive attempted to install have installed fine but the mediatomb rpm reports them missing i tried using the --nodeps argument to see if it would work but it still asks for libjs can someone please point me to where you got yours. I'm using fedora core 3 any help is highly appreciated.

     
    • Jin

      Jin - 2005-07-22

      Hi,

      it's the spidermonkey stuff that is mentioned in the readme. We indeed forgot to say that it is also called "libjs" :P

      You can find it here, I think there is even an rpm for it:
      http://ftp.mozilla.org/pub/mozilla.org/js/

      Kind regards,
      Jin

       
    • toasti

      toasti - 2006-02-14

      Where to put the js-stuff??
      I've installed the newest rpm's for libjs, but it seems not to like them. Which ones are exactly needed?

      Thanks for any help, would be great if it works soon!

       
    • Jin

      Jin - 2006-02-14

      hi,

      which ones did you install and what is your distribution?

      on FC4 I have:
      js-1.5-2.fc4
      js-devel-1.5-2.fc4

      what package are you trying to run? the binary mediatomb rpm's or are you trying to recompile?

      greetings,
      Jin

       
    • toasti

      toasti - 2006-02-14

      I have a SuSe 10.0 and I am trying with the mediatomb rpm.
      Libjs in 1.5-0
      mediatomb 0.8.5

      thx for help.

       
    • Jin

      Jin - 2006-02-14

      hmm, where did you get mediatomb 0.8.5? :) we for sure did not release such a version :)

      well, the rpm packages provided here were built on Fedora; for SuSe you will probably get the source rpm and rebuild it.

      on fedora you would do that by running: rpmbuild --rebuild packagename.src.rpm

      I am not sure if suse has an "rpmbuild" command or if you can rebuild using "rpm" directly. But obviously you will have to install all development headers and recompile mediatomb.

      Let me know if you have problems with that,
      Jin

       
    • toasti

      toasti - 2006-02-15

      sorry, I had the mediatomb 0.8.1

      the thing with rpmbuild --rebuild worked fine.
      The server is up and running, but:
      By playing a file it seems to crash the dsm 320.
      I already installed the lipupnp.

      What to do?

       
    • Jin

      Jin - 2006-02-15

      check out this thread:
      http://sourceforge.net/forum/forum.php?thread_id=1266601&forum_id=440750

      I am pretty sure that your problem is related to this issue. When rebuilding, are you sure that you had the filemagic development headers installed?

      The rebuilding might have worked, but we use a lot of additional; if they are missing the server will work but will provide less functionality.

       

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks