Duplicate Entries

Tinus
2009-07-30
2013-05-30
  • Tinus

    Tinus - 2009-07-30

    I have setup Mediatomb and it's wokring perfectly. The only thing is i get several duplicate entries for each item, anywhere from 2-20 duplicates. It's most noticeable with audio which all have at least 7 or 8 duplicates. Video just has either 2 or 4.
    Anyone recognize this pattern?

    Here's my config.xml (i added some mappings, is that the problem?)

    Thx

    <?xml version="1.0" encoding="UTF-8"?>
    <config version="1" xmlns="http://mediatomb.cc/config/1" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:sch$
      <server>
        <ui enabled="yes">
          <accounts enabled="no" session-timeout="30">
            <account user="Annifun" password="medieluder"/>
          </accounts>
        </ui>
        <name>ANTIN-MEDIASERVER</name>
        <udn>uuid:148a39b1-30d7-4928-a9ad-299f1500db03</udn>
        <home>/mnt/spaces/tinus/.mediatomb</home>
        <webroot>/usr/share/mediatomb/web</webroot>
        <storage>
          <sqlite3 enabled="yes">
            <database-file>mediatomb.db</database-file>
          </sqlite3>
        </storage>
        <protocolInfo extend="no"/><!-- For PS3 support change to "yes" -->
        <!--
           Uncomment the lines below to get rid of jerky avi playback on the
           DSM320 or to enable subtitles support on the DSM units
        -->
        <!--
        <custom-http-headers>
          <add header="X-User-Agent: redsonic"/>
        </custom-http-headers>

        <manufacturerURL>redsonic.com</manufacturerURL>
        <modelNumber>105</modelNumber>
        -->
        <!-- Uncomment the line below if you have a Telegent TG100 -->
        <!--
           <upnp-string-limit>101</upnp-string-limit>
        -->
      </server>
      <import hidden-files="no">
        <scripting script-charset="UTF-8">
          <virtual-layout type="builtin"/>
        </scripting>
        <mappings>
          <extension-mimetype ignore-unknown="no">
            <map from="mp3" to="audio/mpeg"/>
            <map from="ogg" to="application/ogg"/>
            <map from="asf" to="video/x-ms-asf"/>
            <map from="asx" to="video/x-ms-asf"/>
            <map from="wma" to="audio/x-ms-wma"/>
            <map from="wax" to="audio/x-ms-wax"/>
            <map from="wmv" to="video/x-ms-wmv"/>
            <map from="wvx" to="video/x-ms-wvx"/>
            <map from="wm" to="video/x-ms-wm"/>
            <map from="wmx" to="video/x-ms-wmx"/>
            <map from="m3u" to="audio/x-mpegurl"/>
            <map from="pls" to="audio/x-scpls"/>
            <map from="flv" to="video/x-flv"/>
            <!-- Uncomment the line below for PS3 divx support -->
            <!-- <map from="avi" to="video/divx"/> -->
            <!-- Uncomment the line below for D-Link DSM / ZyXEL DMA-1000 -->
            <!-- <map from="avi" to="video/avi"/> -->
          </extension-mimetype>
          <mimetype-upnpclass>
            <map from="audio/*" to="object.item.audioItem.musicTrack"/>
            <map from="video/*" to="object.item.videoItem"/>
            <map from="image/*" to="object.item.imageItem"/>
          </mimetype-upnpclass>
          <mimetype-contenttype>
            <treat mimetype="audio/mpeg" as="mp3"/>
    <treat mimetype="application/ogg" as="ogg"/>
            <treat mimetype="audio/x-flac" as="flac"/>
            <treat mimetype="image/jpeg" as="jpg"/>
            <treat mimetype="audio/x-mpegurl" as="playlist"/>
            <treat mimetype="audio/x-scpls" as="playlist"/>
            <treat mimetype="audio/x-wav" as="pcm"/>
            <treat mimetype="audio/L16" as="pcm"/>
            <treat mimetype="video/x-msvideo" as="avi"/>
            <treat mimetype="video/x-msvideo" as="avi"/>
            <treat mimetype="video/mp4" as="mp4"/>
            <treat mimetype="audio/mp4" as="mp4"/>
            <treat mimetype="video/x-divx" as="avi"/>
          </mimetype-contenttype>
        </mappings>
      <filesystem-charset>ISO-8859-1</filesystem-charset>
       <metadata-charset>ISO-8859-1</metadata-charset>
    </import>
      <transcoding enabled="no">
        <mimetype-profile-mappings>
          <transcode mimetype="video/x-flv" using="vlcmpeg"/>
          <transcode mimetype="application/ogg" using="vlcmpeg"/>
          <transcode mimetype="application/ogg" using="oggflac2raw"/>
          <transcode mimetype="audio/x-flac" using="oggflac2raw"/>
          <transcode mimetype="audio/x-flac" using="audio-common"/>
          <transcode mimetype="video/x-divx" using="video-thumbnail"/>
          <transcode mimetype="video/x-matroska" using="video-common"/>
          <transcode mimetype="video/quicktime" using="video-common"/>
        </mimetype-profile-mappings>
        <profiles>
          <profile name="oggflac2raw" enabled="no" type="external">
            <mimetype>audio/L16</mimetype>
            <accept-url>no</accept-url>
            <first-resource>yes</first-resource>
            <accept-ogg-theora>no</accept-ogg-theora>
            <agent command="ogg123" arguments="-d raw -f %out %in"/>
            <buffer size="1048576" chunk-size="131072" fill-size="262144"/>
          </profile>
          <profile name="vlcmpeg" enabled="no" type="external">
            <mimetype>video/mpeg</mimetype>
            <accept-url>yes</accept-url>
            <first-resource>yes</first-resource>
            <accept-ogg-theora>yes</accept-ogg-theora>
            <agent command="vlc" arguments="-I dummy %in --sout #transcode{venc=ffmpeg,vcodec=mp2v,vb=4096,fps=25,aenc=ffm$
            <buffer size="14400000" chunk-size="512000" fill-size="120000"/>
          </profile>
          <profile name="video-thumbnail" enabled="no" type="external">
            <mimetype>image/jpeg</mimetype>
            <accept-url>yes</accept-url>
            <thumbnail>yes</thumbnail>
            <resolution>128x128</resolution>
            <agent command="ffmpegthumbnailer" arguments="-i %in -o %out -s 128"/>
            <buffer size="524288" chunk-size="512" fill-size="1024"/>
          </profile>
          <profile name="audio-common" enabled="yes" type="external">
            <mimetype>audio/x-wav</mimetype>
            <accept-url>yes</accept-url>
            <first-resource>yes</first-resource>
            <accept-ogg-theora>no</accept-ogg-theora>
            <agent command="mediatomb-transcode-audio" arguments="%in %out"/>
            <buffer size="1048576" chunk-size="131072" fill-size="262144"/>
          </profile>
          <profile name="video-common" enabled="no" type="external">
            <mimetype>video/mpeg</mimetype>
            <accept-url>yes</accept-url>
            <first-resource>yes</first-resource>
            <accept-ogg-theora>yes</accept-ogg-theora>
    <agent command="mediatomb-transcode-video-ffmpeg" arguments="%in %out"/>
            <buffer size="14400000" chunk-size="512000" fill-size="120000"/>
          </profile>
        </profiles>
      </transcoding>
    </config>

     
    • Anonymous - 2009-07-30

      It will be something to do with your import.js file. Check the wiki ...

       
  • Jin

    Jin - 2009-12-03

    Are you sure that you do not have same files in different directories? This could also cause duplicate entries.

     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks