JPG not sorted into directories

  • trigger_d

    trigger_d - 2008-01-12

    All my photos are organised into directories/folders but when added to media tomb and looking at them via the mediatomb web page or my device, they just all come under one directory - "All Photos" is there a way to get mediatomb to preserve the directory tree?  It seems to work fine for mp3's.

    Many thanks

    • Jin

      Jin - 2008-01-12

      Well, you will find the 1:1 mapping with your harddrive in the PC Directory container.

      The MP3 are sorted by id3 tags (if your version of MediaTomb was compiled with id3lib or taglib), you can use the exif information of images and adapt the import js to create a layout of your choice, you could also strip away leading paths and keep the rest of the structure; otherwise just browse the PC Directory.

      Kind regards,

      • trigger_d

        trigger_d - 2008-01-12

        Hi thanks for the info! I'm using a kodak digital photo frame to view the photos over wifi, for mp3's accessing them via the pc directory method works fine.  However, when viewing the pictures it only seems to work if you access the jpg's via "all photos" method, it's as though it doesn't see them as images via pc directory as just displays the file names but via the "all photos" it'll generate thumbnails and slideshow them one by one.  Unfortunatly the frame doesn't have a random function, so always starts from the beginning (date order) and when you've got a few years worth of photo's it'll never get to the end unless left it on for days.  Not sure what you mean by exif info?

        Many thanks

    • nottaken

      nottaken - 2008-01-24

      I also have a Kodak frame EX811.. The PC Directory works fine for me!

      • Jeff

        Jeff - 2008-07-25


        software: mediatomb v0.11.0
        machine: imac Mac OS X 10.5.4
        Kodak digital Frame: EX1011 update: 2007.3.24Worldwide

        I've installed mediatomb v0.11.0 through FINK, everything seemed to install with no errors.  When I start up mediatomb, everything seems to be as it should.  The frame finds the mediatomb server right away.  So at this point I'm in the 'Home' window on the frame with 'Network Computer' highlighted.  I press OK on the remote and nothing happens.  So that is a far as it will go.  The web UI seems to work fine (as far as I know).  I've tried all the suggestions in the manual as well as playing around with the config file.  Still nothing.

        When I came to this forum I expected there to be a thread with people having the same problem I'm having.  Apparently that's not the case.  It seems like everybody basically has it working (with some problems here and there).  I guess what I asking is did anyone have the same problems I'm having at first?  Or any idea what could be causing this?  Also is anyone on the same architecture as me?

        Any suggestions would be appreciated,

    • Ruediger Bente

      Ruediger Bente - 2008-01-29

      I have added this one to the import.js in the function addImage

      /* =========================================================================
          Create own filestructure based on the filesystems structure
          Split full filename and delete the first and last array

      // the basic array
              var myArray = new Array('Photos');

      // split full filesystem name
              var patharray = obj.location.split("/");

      // copy arraymember, beginning with the second (first one is the name of the volume
      // and last one is the filename itself) and ending with that one before the last one
      // for example:  obj.location gives back  /data4/Pictures/Holiday/2007/img_2007.jpg
      //  will be stored under /Photos/Pictures/Holiday/2007
             for(i=2;i<patharray.length - 1;i++)  myArray[i-1] = patharray[i];

      // if there is a name, than add it to the database
              if (myArray[1])

                  addCdsObject(obj, createContainerChain(myArray), UPNP_CLASS_CONTAINER);
      // ========================================================================================

    • Noj

      Noj - 2008-03-15

      How would I use rbente's import script if I needed to begin with the forth instead of second directory? I tried changing i=2 to 4 but it didn't like it. Sorry for the silly question but I'm terrible with scripts.

    • Christian Samsel

      for(i=4;i<patharray.length - 1;i++) myArray[i-3] = patharray[i];

      should do the trick


Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.

No, thanks