Need testers for static packages!

Jin
2008-04-16
2013-05-30
<< < 1 2 (Page 2 of 2)
  • talonso

    talonso - 2008-09-26

    Thanks Jin, the mediatomb-static-0.11.0-r2-linux-uclibc-mips2el.tar.gz solved the CPU load problem on my MSS-1.
    I only just installed it (because dhs.org was down) and so far it looks very good.

    I'll keep an eye on it running for the next few days and report if I find any issues.

    thanks

    -T

     
  • Jin

    Jin - 2008-09-26

    Does inotify detection work correctly for you? I.e., in the web UI, when choosing autoscan settings - is the inotify radio button available for you or not? And if it is - does the feature work on the MSS-1?

     
  • talonso

    talonso - 2008-09-26

    I'll check tonight when I have access to it.
    But I doubt it, MSS-1 is based on kernel 2.4.5.

    -T

     
  • talonso

    talonso - 2008-09-27

    No inotify radio button shows up on the UI.
    I see no inotify support on the MSS-1 kernel.

     
    • rinc0

      rinc0 - 2008-09-27

      I'm using the openmss1 2.6.2 (rc2) firmware.  Seems it uses a newer kernel:

      <4>Linux version 2.4.20 (mxobuilder@calbuild01) (gcc version 3.0 20010422 (prerelease) with bcm4710a0 modifications) #1 Wed Feb 1 15:12:33 PST 2006

      The inotify radio button does appear but inotification does not appear to work.  There is no /proc/sys/fs/inotify directory either - perhaps this should be the test for inotify if not already? 

      I noticed that dnotify is available:

      # cat /proc/sys/fs/dir-notify-enable
      1

      ps: thanks for the cpu bug fix

       
  • Jin

    Jin - 2008-09-27

    There is no inotify on 2.4, there's only the old DNOTIFY mechanism (which we do not support).

    I was asking for this test so we could see how inotify autodetection works with 2.4 (and if it works at all).

    The button should not appear, however we know systems that report that inotify is available, allthough it is not. This seems to be the case with your latest firmware as well; the question there is - if you still try to enable inotify then, do you see extensive CPU usage?

    We had a case where this was happening, of course there is no way for us to fix this, except disabling inotify for these systems and I am trying to figure out which devices are affected.

    Thanks for the test!

    Kind regards,
    Jin

     
    • rinc0

      rinc0 - 2008-09-27

      "if you still try to enable inotify then, do you see extensive CPU usage?"

      And the answer is yes, extensive CPU usage happens when inotify is chosen.   I'll be sure to steer clear of the inotify option on this device.

      Rather than defining which devices are affected I would suggest checking for the /proc/ entry.  Directly accessing /proc/ seems to be common in Linux, and I presume inotify is Linux-specific...

      # /opt/bin/uname -a
      Linux (none) 2.4.20 #1 Wed Feb 1 15:12:33 PST 2006 mips unknown
      # if [ -d /proc/sys/fs/inotify ] ; then echo inotify ; else echo noinotify ; fi
      noinotify

       
  • Jin

    Jin - 2008-09-29

    I am not sure if I can rely on proc (can it be configured out?), we can of course check the kernel version and simply disable inotify autodetection for the kernels where we know that it is not supported (like 2.4), autodetection seems to work well on 2.6.x (at least starting from the kernel versions that know about inotify's existence). I'll have a look...

     
  • Vick Volk

    Vick Volk - 2009-01-23

    I am willing to try on my Asus Wl-500gp v 2 but what really might be a powerhorse is Actiontec  M1424WR recv C, D that is running busy box and reported to work with open wrt. I have these 2 routers with Actiontec collecting dust so far

     
  • Jin

    Jin - 2009-01-23

    Well, the WL500gp test is actually "over" in the sense that we have working packages - they are offered in our download section.

    I am not familar with those actiontec devices, what CPU do they have?

     
  • Vick Volk

    Vick Volk - 2009-01-23

    Here is more info on it http://www.dd-wrt.com/phpBB2/viewtopic.php?t=23514  the CPU is a whooping 450-450 mhz the highest I saw on the home routers and there is some advancement with putting different firmwares on it. The original from verizon is also linux that they have been sued for not supplying the source code. It is now published on actiontec.com. Good luck!

     
  • Jin

    Jin - 2009-01-24

    It's an XScale.. I'll have a look, I think we do not have static packages for that one yet.

     
  • Pablo d'Angelo

    Pablo d'Angelo - 2009-02-15

    I'm trying to run mediatomb on a Samsung SMT-3210, see http://wiki.gpl-devices.org/wiki/Samsung_SMT-G3210 for more information on the device.

    When I try to run mediatomb (mediatomb-static-0.11.0-r2-linux-uclibc-mips32el.tar.gz), I get the following errors:

    # ./mediatomb.sh
    /ramdisk/mnt/usb-storage/FEDORA_SanDisk-U3-0/samsung/mediatomb-mips32el/usr/bin/mediatomb: 1: @4THNP4: not found
    /ramdisk/mnt/usb-storage/FEDORA_SanDisk-U3-0/samsung/mediatomb-mips32el/usr/bin/mediatomb: 1: ELF��: not found
    /ramdisk/mnt/usb-storage/FEDORA_SanDisk-U3-0/samsung/mediatomb-mips32el/usr/bin/mediatomb: 12: Syntax error: "(" unexpected
    #

    If I try to run mediatomb-static-0.11.0-r2-linux-uclibc-mips2el.tar.gz, I get the following error

    # ./mediatomb.sh
    /ramdisk/mnt/usb-storage/FEDORA_SanDisk-U3-0/samsung/mediatomb-mis2el/usr/bin/mediatomb: 1: Syntax error: word unexpected (expecting ")")
    #

    I can run other programs from the same USB-Stick, so it doesn't seem to be a problem with mounting.

    It looks like the static mips binaries were compiled for little endian, while the binaries on the device seem to be compiled for big endian:

    # file oamctl (some binary from the firmware)
    oamctl: ELF 32-bit MSB executable, MIPS, version 1 (SYSV), dynamically linked (uses shared libs), stripped
    # file mediatomb
    mediatomb: ELF 32-bit LSB executable, MIPS, version 1 (SYSV), statically linked, stripped

    Is it possible to recompile mediatomb in big endian? The cross compiler is available at http://wiki.gpl-devices.org/wiki/Samsung_SMT-G3210#Build_Tools

    I could probably try myself, but building all the dependencies correctly would take me quite some time, I fear.

    Thanks
    Pablo d'Angelo

     
  • Jin

    Jin - 2009-02-15
     
    • Pablo d'Angelo

      Pablo d'Angelo - 2009-02-16

      Hi Jin,

      the http://www.deadlock.dhs.org/jin/mt/STATIC_PACKAGES/mediatomb-static-0.11.0-linux-uclibc-mips2.tar.gz works on my Samsung SMT-3210. Thanks a lot!

      cheers,
      Pablo

       
    • Rudi Ludwig

      Rudi Ludwig - 2009-02-23

      Hello,

      I run the mips2el package release 2 (linked from mediatomb.cc)
      mediatomb-static-0.11.0-r2-linux-uclibc-mips2el.tar.gz

      on a hp mv2010 (mv1, the first generation); see http://www.k0lee.com/hpmediavault/ (not my page)

      HW / SW:
      # cat /proc/cpuinfo
      system type             : Broadcom BCM947XX
      processor               : 0
      cpu model               : BCM3302 V1.10
      BogoMIPS                : 299.82
      wait instruction        : no
      microsecond timers      : yes
      tlb_entries             : 32
      extra interrupt vector  : no
      hardware watchpoint     : no
      VCED exceptions         : not available
      VCEI exceptions         : not available

      # cat /proc/version
      Linux version 2.4.20 (root@localhost.localdomain) (gcc version 3.0 20010422 (prerelease) with bcm4710a0 modifications) #11 2007å¹´ 04æ 06æ¥ ææäº 13:07:54 CST

      (yes those garbage characters are original, don't ask me.)

      Observations:
      Selecting scan option inotify makes one of the ten mediatomb processes hook the CPU, as was written in earlier post in this thread.
      -> Suggest to add this information to the "Readme.txt"

      Using file tag information to create the virtual folders is an issue. It seams only mp3 file tags / files are recognized and this not reliably. That is, non of my flac files is sorted in the v. folders and from the one CD that I ripped as mp3 two of eleven songs are not recognized and filed under "unknown".
      I can however copy all those files to the scanned folder on my other computer (x86 laptop) -running freebsd 7.0 with mediatomb 0.11 from ports- and all above files are sorted correctly into the virtual folders.
      -> Accidently compiled with a broken imlib instead of taglib ?

      ---------
      With the mips2el as well as the mips32el that are linked in the post from 2009-02-15 I had no luck.
      when executing eg. mediatomb directly

      # usr/bin/mediatomb -h
      mediatomb: applet not found

      same result with ./mediatomb.sh

      It seams you mistakenly linked a previous archive version in that message. Files from the packages have a modified date from 2008-04-17
      while in the (supposedly older) r2 they are dated 2008-09-22
      (I downloaded the files on 2009-02-17)

      Regards,

      Rudi

       
  • joban1

    joban1 - 2009-02-16

    I want to report success for using mediatomb static packages on a dreambox dm7020 (ppc) and a dreambox dm800 (mips32).

    It is possible to play the ts files (including hd material) on a playstation 3, including seeking: great.

    I had only very limited time for testing, but so far it all works very well.

    Btw. what is the difference between the mips32 and mips2 build?

     
  • Jin

    Jin - 2009-02-17

    Joban, did you use the mips32el package from the download page?

    MIPS2 and MIPS32 are slightly different CPU versions, I believe that MIPS2 stuff should run on MIPS32 as well  (correct me if I'm wrong), however it turned out that this was not the case with some embedded devices.

    Pablo, I will add the mips2 build to the download section, thanks for testing!

    Kind regards,
    Jin

     
  • Hubert Becker

    Hubert Becker - 2009-04-10

    Hi
    I am running mediatomb-static-0.11.0+svn20081125-r3-linux-uclibc-ppce300c2.tar.gz also mediatomb version 0.11.0-3 is already in the repository on ALLnet 6250 NAS with opennas firmware:

    opennas:~/111/mediatomb# cat /proc/cpuinfo
    processor       : 0
    cpu             : 82xx
    revision        : 16.20 (pvr 8081 1014)
    bogomips        : 176.94
    vendor          : Motorola
    machine         : MPC8241
    processor       : PVID: 0x80811014, vendor: Motorola
    opennas:~/111/mediatomb# cat /proc/version
    Linux version 2.4.32 (christian@debianMobile) (gcc version 3.4.6) #1 So 27. Jul 22:12:46 CEST 2008

    Normally it works quite good so far.
    But i got a new TV Samsung LE40B650 with DLNA support and tried to use it with mediatomb. But no succes so far.
    My hope was this version of mediatomb would support my TV.

    But my TV says again with all my musik, videos, pictures:

    file format not supported.

    Any idea's or help would be appreciated.

    Regards

    Hubert

     
  • duncan  ellis

    duncan ellis - 2009-06-13

    Hi

    I've just loaded the static package for the ARMv4 onto the Buffalo Terastation 2. Couple of things I cant work out. Firstly is how to get it to autostart (i can start it manually) and the second is that my controlpoint software will not see the library

    Anyone help here???

    BTW everything discovers correctly, I just cant see the library

    Thanks

     
  • Manishee

    Manishee - 2009-07-29

    Hi,

    I am would like to run media tomb on Linksys NSS6100. I am already happily using Mediatomb on NSLU2.

    I have console access to NSS6100 and I copied the static package on the hard disk area, but I get error executing binary.

    [root@NSS6100 ~]# tar -zxvf /mnt/RAIDB/FTP/ftp/mediatomb-static-0.11.0-r2-linux-uclibc-mips2el.tar.gz
    ...
    [root@NSS6100 ~]# cd mediatomb/
    [root@NSS6100 mediatomb]# ./mediatomb.sh
    ./mediatomb.sh: line 10: /root/mediatomb/usr/bin/mediatomb: cannot execute binary file

    Here is the processor information
    [root@NSS6100 ftp]# cat /proc/cpuinfo
    system type             : PMC-Sierra PM74100
    Hardware Revision       : 3
    processor               : 0
    cpu model               : RM9000 V12.1  FPU V2.0
    BogoMIPS                : 899.07
    wait instruction        : yes
    microsecond timers      : yes
    tlb_entries             : 64
    extra interrupt vector  : no
    hardware watchpoint     : yes
    ASEs implemented        :
    VCED exceptions         : not available
    VCEI exceptions         : not available

     
  •  buedi

    buedi - 2009-11-14

    I´d like to try your Static Builds with my NAS. I tried all 4 available Static Builds, but none did run.
    Maybe my cat /proc/cpuinfo helps finding out which Architecture it uses? I have a Twonky 3.1 running on the NAS which was preinstalled, but is outdated. So I´d like to give mediatomb a shot :-)

    ---cat /proc/cpuinfo-----
    Processor       : XScale-IXP4xx/IXC11xx rev 1 (v5b)
    BogoMIPS        : 527.56
    Features        : swp half thumb fastmult edsp

    Hardware        : ADI Coyote Residential Gateway
    Revision        : 0000
    Serial          : 0000000000000000

    ---cat /proc/version-------
    Linux version 2.4.31-uc0 (nasdrive@) (gcc version 3.2.1) #198 Fre Apr 13 17:23:05 CEST 2007

    I hope we can get it running somehow :-)

    Kind regards!

     
<< < 1 2 (Page 2 of 2)

Log in to post a comment.