Need testers for static packages!

1 2 > >> (Page 1 of 2)
  • Jin

    Jin - 2008-04-16

    Hi everyone,

    I am currently working on static packages of MediaTomb that can be used as an addon to the existing firmware of various NAS devices. The idea is, that once you have telnet access to your NAS you can simply use the precompiled static binary without any need to reflash the unit with some custom firmware and without having to worry about dependencies - those packages should run on existing vendor firmware.

    Unfortunately I do not have much devices to test with, so will I rely on your feedback.

    If you have a NAS, be it an Iomega unit, a WD MyBook, or anything else, or a router like the WL500g and if you are willing to test the static packages - please drop me a mail to: jin at mediatomb dot cc

    Once we are sure that the packages work I will make them available for download for everyone.


    • B4tm4n

      B4tm4n - 2008-04-17

      Would it be possible, in the future, for the main app to become compilable without having to worry about dependencies ?
      Is this something allready planned for to do at some time or would it be impossible ?

      Cheers, and thanks for MediaTomb.

    • Jin

      Jin - 2008-04-17


      this is not planned and will not be done. Of course one could create a source tree where all libraries are pulled in and adapt the build environment accordingly, but I do not think that there is any point in doing that.

      Kind regards,

    • Ted

      Ted - 2008-04-29


      I have a Synology 107+ (Marvell processor) and I am ready to do some testing


    • Jin

      Jin - 2008-05-01


      thanks for your response!

      Currently I seem to have some difficulties with the Marvell Orion based devices, the first tested packages had some problems. I'm working on an update, let's see how that goes.

      Could you please drop a mail to jin at mediatomb dot cc ?


    • Dave

      Dave - 2008-06-05

      I am running the static build package on a WL500GP.  It appears to run correctly, but it uses 100% of the CPU, even after finishing indexing.  Also, indexing in itself takes forever (it has been running 4 days now but will possibly stop today).

      I build packages for this device now-and-then, such as custom code I have written, or incorporating other packages into the buildroot, so if I could have some form of instructions on how the static package was built, I may be in a posistion to help debug this issue myself.


    • rosenhauer

      rosenhauer - 2008-06-11

      I'd be willing to test a FreeNAS edition (if it will support the DirecTV DVR).  I'm also looing at getting a MyBook World Edition (in the next week or so) and would be willing to test on that also.


    • Jin

      Jin - 2008-06-12

      I think MT is already part of FreeNAS, however I can't say what version. DirectTV - is it the HR20 stuff? If yes, you'll need latest SVN. Btw I won't be doing static packages for FreeNAS, I think it targets x86 anyway.

      There are some known problems with static packages on the MyBook (and on all Marvell Orion based boards), unfortunately this needs some heavy debugging, tests on user level have already been done but at this point I need to dig in - which I can not do due to the lack of this hardware. You can still use the Optware stuff for the MyBook though, that will work.

      Thanks for the testing offer :)

      Kind regards,

    • rosenhauer

      rosenhauer - 2008-06-12

      Yes, I'm talking about the HR20 stuff.  But the FreeNAS package is 0.10.0 so I'm looking at getting it upgraded to the one that supports the HR20.  Any possibility of releasing a 12??? version soon or do I need to just bite the bullet and go the SVN route?  Currently I'm having issues where it's needing a version of a compenet that it appears that I have but it's not recognizing it (need to brush up on my unix!)

      On the MyBook are the issues with using static packages or with running MediaTomb on this hardware?  All I'm planing on using it for it to server music and photos to the HR20 (I'm assuming trying to transcode video is beyond the CPU of the MyBook).  When (thinking positive) I get this all working I'll post a writeup of what I did to get it going. 

    • Jin

      Jin - 2008-06-12

      I can't really say anything about FreeNAS, I only know that it is based on FreeBSD and since our stuff works for FreeBSD - you should be able to compile SVN if you get a build environment and all dependencies.

      By saying "soon" we have been wrong a number of times in the past, so there is no release date. Yes, it is planned "soon", but that can be as soon as 2 weeks or a month and a half, I wouldn't wait.

      Regarding the MyBook: the problem is only with my static builds, I do not think that this is directly related to the hardware, but probably to something in the kernel, I really do not know. Users reported that they were able to run the server, but it did not bind to any network interface and SSDP did not work.

      Again, it works with the Optware packages, the problem is only in my static build.

      Btw, from what I read - photos on the HR20 is no fun at all, it seems to be displaying thumbnail resources instead of the correct images, that needs to be fixed in the HR20 firmware.

    • boilerjt

      boilerjt - 2008-06-12

      The HR2x seems to have 2 issues with photos.  The first is with high resolution photos in which it seems to timeout displaying the image, then it displays the second image available which is the thumbnail.  The second issue is it has problems with some EXIF metadata in the photo file and it gives an "Unable to display..." message.  There is a transcoding procedure for these issues posted in the wiki.

    • Anonymous

      Anonymous - 2008-06-28


      I succesfully installed the mediatomb-static-0.11.0-r1-linux-uclibc-mips32el.tar.gz package on my Emtec R-500 movie cube. Firmware 2.0.9UP. Processor MIPS32.

      The plan was to use the R-500 in combination with the Playstation 3.

      Everything except avi's worked out of the box (after changing the protocolInfo to yes). After some tweaking in the extension-mimetype i got the avi playback working.

      I replaced the extension-mimetypes with :

      <map from="avi" to="video/x-divx" />
      <map from="vob" to="video/mpeg" />
      <map from="mp3" to="audio/mpeg" />
      <map from="ogg" to="application/ogg" />
      <map from="asf" to="video/x-ms-asf" />
      <map from="asx" to="video/x-ms-asf" />
      <map from="wma" to="audio/x-ms-wma" />
      <map from="wax" to="audio/x-ms-wax" />
      <map from="wmv" to="video/x-ms-wmv" />
      <map from="wvx" to="video/x-ms-wvx" />
      <map from="wm" to="video/x-ms-wm" />
      <map from="wmx" to="video/x-ms-wmx" />
      <map from="m3u" to="audio/x-mpegurl" />
      <map from="pls" to="audio/x-scpls" />

      and now i have avi playback on the PS3. Also posted on (Emtec user forum)

      btw : A wonderful piece of software !

    • Jin

      Jin - 2008-06-28

      Thanks for the feedback! I'll add your device to the list in the static packages section on our download page.

    • Rene_Kl

      Rene_Kl - 2008-07-03


      installed mediatomb-static-0.11.0-r1-linux-uclibc-mips2el.tar.gz
      on a AVM FRITZ!Box Fon WLAN 7270 (ADSL Router) and it works perfectly together with my PS3. Streaming of HD material (wmv + divx) from a USB attached WD Passport Drive works like a charm.

      What a great piece of Software!

    • Jin

      Jin - 2008-07-04

      Thanks for the info, I will add this info to the download page, I'm glad to see that the static packages turned out to be useful and are working.

    • Sadler

      Sadler - 2008-07-13

      Hi, I have a Giganas 35HD-DUAL-NAS-E and an Acer AT37050-MGW. I've successfully installed the static armv4 build and the TV sees it and can drill down to various levels. This is my first experience of mediatomb so I don't really know what to expect but the TVs media gateway crashes whenever I try to access any content.  I have to cycle the TV to get back in.  The mediatomb still seems to be indexing - I don't know if this will affect the ability to access media.  I guess I'll try again when it's finished. Thanks.

    • Jin

      Jin - 2008-07-14

      Last time I tried with the ACER TV it worked; basically - check if there is a firmware upgrade available, if not complain @ their support line, with some luck they might fix it.

      Another possibility (which of course makes me less happy ;) - we could compare the XML with servers that work with this device and see if we can add something to work around the bugs in the TV's firmware.

      Gegarding indexing: well..unfrotunately that's indeed not so fast, the upcoming 0.12 release will have some improvements regarding import speed, but especially on smaller/slower devices import can take quite some time :>

    • edriss

      edriss - 2008-07-16

      Hi Jin,

      Any word on whether the issues for the QNAP 209 box was resolved?  This was regarding the fact that there appeared to be no SSDP broadcasts being sent by the static package to advertise itself.


    • Jin

      Jin - 2008-07-16


      unfortunately I could not get such a device for testing, so the issue is not resolve and it will not be resolved unless I get a chance to do some debugging on this hardware.

      Kind regards,

    • rinc0

      rinc0 - 2008-08-16

      I have a Maxtor MSS-I.  The current release candidate (mediatomb-static-0.11.0-r1-linux-uclibc-mips2el.tar.gz) suffers the 100% CPU bug.  Otherwise works great.

      • talonso

        talonso - 2008-09-11

        Same here, Maxtor MSS-1+ running (mediatomb-static-0.11.0-r1-linux-uclibc-mips2el.tar.gz) eats nearly 100% CPU.

        I like the functionality, but I found other problems as well:

        1) On startup at the initial scan the playlist.js readln() return nothing; all playlists show up empty. I have to use the UI to remove the playlists and add them again. Then it work fine.

        2) I have setup timed Full rescan, but it never rescans.

        I'd like to debug the issues and help find fixes by sending log files etc.
        Should I try (mediatomb-static-dbg-log-0.11.0-r2-linux-uclibc-mips2el.tar.gz) or some other package to gather more info?

    • Pico

      Pico - 2008-09-07

      i've a Raidsonic IB-Nas4220-B. Mediatomb is running fine on this device.
      I used Arm4 Static Binary.

    • Jin

      Jin - 2008-09-09

      Thanks for the info guys.

    • Jin

      Jin - 2008-09-12

      Well, I just need to find the time to recompile it for mips2, as you know I fixed the issue for mips32... I'll try to do it soon :)

      Regarding the initial scan and the playlists: I think this is a known bug which has been submitted to the bugtracker (please check if it is really the case, if not submit it), I will have to look at this for the 0.12 release.

      Thanks for the offer for logs/etc, but the issue has been fixed, it's just that I was not aware that people had the same problem on other devices. (Well, the issue would have happened on any device without a realtime clock, but I was too lazy to rebuild it with the fix for all archs since I only had complaints from mips32el package users ;) I'll see that I build a mips2el package for you soon.

      Kind regards,

    • Jin

      Jin - 2008-09-22

      OK, could you please test this one:

      It has the same patches as the mips32el one which should fix the 100% CPU usage bug.

      Let me know if it worked, I'll release the package on SF then.

1 2 > >> (Page 1 of 2)

Log in to post a comment.