Version 0.81

Konni
2005-08-18
2013-05-30
  • Konni

    Konni - 2005-08-18

    How is the status with version 0.81 ?
    Will there be long until the release ?
    WIll there be debian package available in that release ?

    Cheers,
    Konni.

     
    • x_gen

      x_gen - 2005-08-18

      Hi there!

      Version 0.81 will be released in a few days. Everything is implemented and we are currently finishing stress-testing it.

      As for binary package - this will be somewhat problematic.

      Mediatomb may now work with many more libraries. There is true disaster with version compatibility of those libraries on different distros. I think we'll simply build statically linked binary packages, that will naturally have bigger executables, but at least they will work everywhere.

      So, stay tuned ;-)

       
    • Jin

      Jin - 2005-09-05

      As usual "a few days" turned to be out a little more.
      We ran into a few troubles, but hope to get everything done this week. Sorry for the delay :>

       
    • x_gen

      x_gen - 2005-09-08

      Hey! Once the 0.81 release was there we were in a mood to say, no binary packages. Was a temporary blackout :) We're working on rpm's and debs, will come shortly...

       
    • Konni

      Konni - 2005-09-09

      Brilliant ..
      Looking forward to get the Deb.

      Cheers and congrats with v.0.81

       
    • Konni

      Konni - 2005-09-15

      Any news on the deb or the rpm for v. 0.81 ?

       
      • Martin Heerling

        Martin Heerling - 2005-09-15

        Hi,
        I prepared a spec file for mediatomb-0.8.1 for SuSE 9.x. with some support files. You'll find them here:
        http://www.netzwerk-aktiv.com/~mheerling/mediatomb/0.8.1/

        Since I'm running mediatomb under UID nobody, you will have to copy the file /usr/share/mediatomb/start to ~nobody/.mediatomb/start or whatever user you'll pick to run mediatomb.

        Attention: It compiles only if libmagic (here: from file-4.13-5 rpm) contains the shared libs libmagic.so.*. Otherwise the compile bails out stating it cannot find libmagic.

        To compile, copy {mediatomb-0.8.1.tar.gz,mediatomb.rc,start} to /usr/src/packages/SOURCES/ and mediatomb.spec to /tmp/. Then issue "rpmbuild -ba /tmp/mediatomb.spec". After successfull build you will find the binary in /usr/src/packages/i?86/mediatomb-0.8.1-1.i?86.rpm, depending on your RPM architecture build flags (could be ...athlon... as well, though).
        Install it via "rpm -Uvh mediatomb-0.8.1-1.????.rpm and then "su - $YOUR_USER" and "/usr/bin/tomb-install" as mentionend in the README/INSTALL docs.

        Contact me if you need more info.
        Cheers,
        Marv

         
        • Jin

          Jin - 2005-09-16

          Cool stuff! Thank you!
          One remark though, you really should not --enable-libextractor by default, it significantly slows down media import.

          First problem that I observed: no matter how much RAM you have, during import it eats up 80% making everything to run very slowly. The second thing I observed: it sometimes takes ages till it scans through a videofile to extract the metadata.

          I plan to do some tests and report to the library maintainers, but for now I would disable it in spec files and packages. People who really want it can still force it during recompile.

          I am also going to finally update our project homepage, if you don't mine I would upload your suse files along with the description on how to use them.

          Greetings,
          Jin

           
      • Jin

        Jin - 2005-09-18

        OK k0nni, I have just uploaded RPMs for the 0.8.1 release... I hope your alien conversion works out. I would really take a look at how to compile the stuff if I were you :>

         
        • Konni

          Konni - 2005-09-19

          Well I have already tried to compile the package without luck.
          I followed the instructions on compiling the libupnp-1.2.1 in details, but every time i run ./configure i get the same results ..
          "checking for upnp/upnp.h... no
          configure: error: upnp/upnp.h not found. Check libupnp installation"

          And yes i did copy ixml.h to /usr/include

          I also trid installing the patched upnp package that you provided with .. the rpm gets successfully installed but i still get the same error message while running ./configure

          Any ideas ?

           
    • Jin

      Jin - 2005-09-15

      Well, Gena is currently moving, he started on a .deb package but it is not yet ready.

      Regarding rpm packages: I will make a 0.8.2 release this weekend, there will be no new features but the fixes for compiling under SuSE will be in.. for that release I plan to upload precompiled rpm packages for FC3 and FC4.

      Btw, it is quite easy to make an rpm package yourself, just run rpmbuild -tb mediatomb-0.8.1.tar.gz
      that should do the trick on an rpm based system. However I do not know if you can install rpm build tools on debian...(and that is what you are using, right?)

       
    • Konni

      Konni - 2005-09-15

      Yes, I'm running debian,
      dont know about the rpm tools ,
      but I have just the "alien" command to convert rpm package to deb package.

       
    • Jin

      Jin - 2005-09-19

      well, you say you copied it to /usr/include

      your upnp headers should be in /usr/include/upnp

      my /usr/include/upnp directory contains the following files:
      config.h    iasnprintf.h  ixml.h        ThreadPool.h   upnp.h
      FreeList.h  ithread.h     LinkedList.h  TimerThread.h  upnptools.h

      out your stuff accrodingly, and the configure file will try it, just give it another go!

       
    • Konni

      Konni - 2005-09-19

      Works like a charm .. i also needed to copy these files to my /usr/include/upnp folder ..
      config.h, upnp.h and upnptools.h.

      After that, compiled and working ..
      thanks for the help.

       

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks