Static Binary for atheros chipset: ar71xx

  • Anonymous - 2010-06-02

    There are a number of routers these days with the atheros chipset. It would be great if there was a working static build for this architecture. Could the developers please try compile one? I'd be willing to test it on my router which is a TP-LINK TL-1043ND.

    Other routers using the same family of chip set: Buffalo WZR-HP-G300NH, Cisco WRT160NL - complete list:

    My attempts so far:

    I have found a ipk: mediatomb_0.11.0-5_mips.ipk from which after painfully install all the dependencies still did not want to work on my router; mediatomb starts but just hangs. I don't think this is the correct build for the ar71xx.

    I see the startup banner if I start mediatomb from the console/telnet but it doesn't show the URL as a poster mentioned in

    If I start up using the init script "S90mediatomb start" then it just freezes at "Starting mediatomb:", the log file also reads:
    2010-05-02 03:28:28 INFO: Loading configuration from: /opt/etc/mediatomb/config.xml
    and nothing more. top shows mediatomb process taking up 100% of CPU and about 25% of memory. It doesn't accept incoming connections on the port.

    I tried using -debug and -D but those switches are not supported by my build.

    I tried simply my config.xml (in /opt/etc/mediatomb)to the bare minimum but still freezes.

    THANKS !!!!

  • Jin

    Jin - 2010-06-03

    Is it a MIPS architecture? If yes, yоu might want to try the static binaries from our download page, I think there should be two MIPS variants there. I still did not have the time to update the static packages to 0.12.1, this is on my TODO list.

    Our static binaries do not require any dependencies.

  • Anonymous - 2010-06-16

    I tried both MIPS static packages and neither worked. Perhaps it isn't MIPS and my confusion was because of the folder where I got the package (atheros) as opposed to ar71xx. atheros is for older chipsets while ar71xx is for later atheros chipsets.

    Hence I guess a static binary for ar71xx architecture would need to be built.


Log in to post a comment.