os x 10.3.9?

  • Anonymous - 2007-08-06

    Trying to install via fink and get build error shown below.

    g++-3.3 -DHAVE_CONFIG_H -I. -I. -I.. -I../tombupnp/upnp/inc   -DXP_UNIX=1 -I/sw/include -I../src -I../tombupnp/ixml/inc -I../tombupnp/threadutil/inc -I../tombupnp/upnp/inc -I..    -I/sw/include/js        -D_THREAD_SAFE  -g -O2 -c -o libmediatomb_a-autoscan.o `test -f '../src/autoscan.cc' || echo './'`../src/autoscan.cc
    In file included from ../src/autoscan.h:37,
                     from ../src/autoscan.cc:36:
    ../src/zmm/ref.h: In destructor `zmm::Ref<T>::~Ref() [with T = Mutex]':
    ../src/sync.h:52:   instantiated from here
    ../src/zmm/ref.h:62: error: `release' undeclared (first use this function)
    ../src/zmm/ref.h:62: error: (Each undeclared identifier is reported only once
       for each function it appears in.)
    make[2]: *** [libmediatomb_a-autoscan.o] Error 1
    make[1]: *** [all-recursive] Error 1
    make: *** [all] Error 2

    • Jin

      Jin - 2007-08-06

      That must be something special to gcc-3.3, we'll have to take a closer look.

      If you don't mind you could try a newer gcc version, otherwise we will come back to you on this.

    • Anonymous - 2007-08-07

      OK, thanks. Discovered I was missing the nov 2004 gcc update. Installed and tried again: success! Now to figure out how to use MediaTomb.

      PS: You can probably tell from this that I haven't had much use out of my Mac Mini, bought on the day they arrived in the UK. For me it became almost immediately defunct when 10.4 arrived only 3 months later and I couldn't justify another 20/25% on top of the original cost. So I'm looking forward to *finally* getting some practical use out of it as a media server... so thanks for supplying MediaTomb!

    • Anonymous - 2007-08-07

      Progress: compiled and runs ok. One problem left is getting it to detect the file type and use the correct mime type when adding files. After a detour into installing imagemagick (don't ask we why, I saw "magic" and thought it needed it) and help from AKH on Fink irc, I see now that what is being refered to is the "file" command. I tried this on an image file and the correct mime type was returned so why won't MT see it/ use "file"?

    • Jin

      Jin - 2007-08-07

      Doh... why didn't you just look at the documentation? It explains all required/optional dependencies and also gives details on what libmagic is and how it is used. But well, imagemagick is actually very useful software, so your effort is not fully wasted :)

      Anyway... I have to talk to the Fink people, I do not know if Fink compiles MediaTomb with or without libmagic (it's a highly recommended, but optional dependency). If you compile MediaTomb with libmagic support, then mimetypes will be autodetected. I do not know much about Fink - I do not have an OS X machine so unfortunately I can not give much support here. I'm already happy that Fink devs had the time to create an MT package and add it to Fink.

      So.. what you need is a MediaTomb version compiled with libmagic support...

    • Anonymous - 2007-08-08

      "doh" indeed :) My mistake for skimming the doc's. Once you corrected me (on irc) about "file" I then, via fink, installed the file-dev package from "source" and rebuilt MT. On re-adding my media MT correctly determined all the mime types and also served them up without any further changes.

      I'm off to give the doc's a thorough reading now ;)


Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks