Anonymous - 2012-08-05

I just setup mediatomb because my current DLNA server doesn't support transcoding very well.
Mediatomb works fine for direct-stream files, but when I enable transcoding it dies every time I open a file.

In standard mode, nothing was written to the log file, so I tried debug mode. This is the output beginning from the moment I tried to open a file:

2012-08-05 04:07:56   DEBUG: [../src/web_callbacks.cc:72] create_request_handler(): Filename: /content/media/object_id/15/res_id/0/ext/file.mkv, Path: (null)
2012-08-05 04:07:56   DEBUG: [../src/file_request_handler.cc:345] open(): start
2012-08-05 04:07:56   DEBUG: [../src/file_request_handler.cc:360] open(): full url (filename): /content/media/object_id/15/res_id/0/ext/file.mkv, parameters: object_id/15/res_id/0/ext/file.mkv
2012-08-05 04:07:56   DEBUG: [../src/file_request_handler.cc:370] open(): Opening media file with object id 15
2012-08-05 04:07:56   DEBUG: [../src/file_request_handler.cc:506] open(): path: /pub/elements/TV/Fringe/Season 4/Fringe.S04E01.720p.HDTV.X264-DIMENSION.mkv
2012-08-05 04:07:56   DEBUG: [../src/file_request_handler.cc:519] open(): fetching resource id 0
2012-08-05 04:07:56   DEBUG: [../src/file_request_handler.cc:671] open(): Adding content disposition header: Content-Disposition: attachment; filename="Fringe.S04E01.720p.HDTV.X264-DIMENSION.mkv"
2012-08-05 04:07:56   DEBUG: [../src/singleton.cc:73] registerSingleton(): registering new singleton... - 9 -> 10
jobs

After that the process is killed with exit code 139. When running with the daemon it's restarted, only to die again whenever I try to open a file.

This is how I enabled "transcoding" in my config.xml (I'm using a null transcoder which simply copies everything here, because the more complicated one didn't work and I was trying to find the simplest thing which doesn't work):

  <transcoding enabled="yes">
    <mimetype-profile-mappings>
      <transcode mimetype="video/*" using="panasonic" />
    </mimetype-profile-mappings>
    <profiles>
      <profile name="panasonic" enabled="yes" type="external">
        <mimetype>video/mpeg</mimetype>
        <accept-url>yes</accept-url>
        <first-resource>yes</first-resource>
        <accept-ogg-theora>yes</accept-ogg-theora>
        <agent command="mencoder" arguments="%in -oac copy -ovc copy -o %out" />
        <buffer size="2097152" chunk-size="524288" fill-size="1048576" />
      </profile>
    </profiles>
  </transcoding>

Any ideas?
Thanks