File not supported - in middle of playing

  • -DK-

    -DK- - 2005-11-09

    The last couple of nights after getting the stuttering problem under control, we have been getting some playback issues.

    After watching a file for any length of time, it sometimes just stops and then the "File not supported" message is displayed on screen. This comes up at what seems to be random times in the file. I can search to the time stamp where the file shut down and resume playing no problem but usually the problem occurs again.

    Any ideas what might be causing it? I have looked through the logs and there is nothing that says there was an error...


    • Jin

      Jin - 2005-11-10

      Hmm.. first I thought it may be the known 2GB limitation, but since it is appearing randomly it must be something else.

      Are you using a wired or a wireless connection?

      Also, Jason indicated that my libupnp patch is not complete, maybe this happens because KEEP-ALIVE support is not enabled, I will look into that.

      Generally speaking, I doubt that this is a MediaTomb problem, this is mostprobably related to the SDK (after you started streaming you are basically "downloading a file from a webserver", which is a straightforward operation, so either the connection gets interrupted or something goes wrong with the internal webserver). I will once a gain look at the SDK to put in the changes that I overlooked in Jasons's patch, could you by chance make an ethereal log of the problem? That is usually helpful to analyze network problems.

      If you need help with ethereal let me know.


    • -DK-

      -DK- - 2005-11-10

      I suspected that it was due to the DSM320 losing touch with the server. I have no idea how to create an ethereal log so please enlighten me and I'll post the results.

      Is there an easy way for me to go into the src RPM and enable KEEP-ALIVE support?

      I can do that for you and upload the changes if you like.



    • Jin

      Jin - 2005-11-12

      You did not answer if you use a wired or a wireless connection :)
      In case of a wireless connection I would not really bother with ethereal, because there it is obvious that it may become unstable and just break off.

      I assume that you did not have this particular problem with the default server that comes with the DSM320?

      Anyway.. hopefully I will find some time on Sunday to take a look at the KEEP-ALIVE changes.

      There is however one thing that you could do to test if KEEP-ALIVE is really causing the problem. You could install apache, and add an "External URL" in MediaTomb, entering a link to your item which should be streamed from your apache server. So you will browse the item on MediaTomb, but you will stream it from your own webserver. Would be interesting to see if the problem appears there as well. You could also add the "X-User-Agent: redsonic" header to your apache, see this link for information on how to do it:

      So... in case you are bored... maybe you could give this a go :)

      Kind regards,

    • -DK-

      -DK- - 2005-11-12

      Sorry I didn't specify my connection. I am running on a wired connection :)

      The problem does not occur with the D-Link software so I have been using that until we can nail down this issue.

      I believe that I have apache already running on the server but I'm not certain how to configure it to do the things that you suggest. I'll do some looking into it and see what I can figure out. I don't think that I'll have a chance to play around with it before sunday either as the weekend is getting busy.

      I'll give the link you posted a look and see what I can figure out with it.


    • -DK-

      -DK- - 2005-11-20

      Is there any word on an updated file with the "keep-alive" support added?

      I have not been able to work through the apache server fix... I just haven't had the time to figure it all out.

      Thanks in advance,


    • Jin

      Jin - 2005-11-20

      well, not yet, sorry :) I had too much work...

      however, Jason indicated that his keep-alive patch does not work well...

      regararding apache, I'll take a look, maybe I can create some config files for you, so you can test that easily

      Kind regards,

    • -DK-

      -DK- - 2005-11-20

      Being busy is understandable; I'm not trying to be a bother, but curious really.

      If you have time to send along some config files that would be fantastic, or even the keep-alive patch (just to see what happens on my end) that would be great!

      Hope things are well,


    • Jin

      Jin - 2005-11-27


      ok, sorry it took so long but I finally found some time to look into this thing. Surprisingly, it was very easy to set it up. Here is what you do:
      edit your /etc/httpd/conf/httpd.conf (thats the location on Fedora systems)

      Go to the <Directory> section, to the one where you serve the files from. Let's assume the default:
      <Directory "/var/www/html">

      in the next line add this:
      Header add X-User-Agent "redsonic"

      restart apache, in mediatomb add an "External URL" item, make sure to enter the correct mimetype (if in doubt use file -i yourmediafile in the console), point the URL to the file which is on your apache server (something like http://yourinternalserverip/yourfile.avi\)

      now you should be able to stream this file from your DSM-320...

      I am very interested in hearing the results :)

      good luck!

    • -DK-

      -DK- - 2005-12-02

      Sorry that I missed this post but I got busy this past week.

      I tried out your suggestion tonight and I just can not get this to work.

      I get the "Unable to open file" dialogue box no matter what I do. I have tried adding both an external link and an internal link (the internal link just gives me an error when I try to add anything).

      When I open a browser and enter in: I can download the file so I know the http server is working right that way.

      Is there anything that you can suggest?

    • Jin

      Jin - 2005-12-02

      well, an internal link will not help you in that case; actually internal links make sense in very rare situations and were added to allow java-game download for Streamium clients.

      external link is what you need...
      ok, let's try this walkthrough:
      I assume you found the menu for adding external links.. so here is what you fill in:
      Object Type: External Link
      Title: whatever
      Protocol: http-get
      Class (usually that does not matter, but as far as I know the DSM320 pays attention to this: object.item.videoItem
      Description: you can leave this empty
      Mimetype (check with file -i ER.S12E08.avi), I will assume it is: video/x-msvideo

      After hitting the "Add Object" button you should have everything working...

      Thanks for trying,

    • -DK-

      -DK- - 2005-12-02

      That is exactly how I added the file in the web browser. However I get the "unable to play file" dialogue and can not get around it.

      I think that it must be something to do with the apache config...

    • Jin

      Jin - 2005-12-02

      hmm.. that's odd... maybe apache provides a different mimetype, and the DSM320 treats the mimetype from the webserver with a higher priority than the one obtained via UPnP? that's only a guess, however.

      we have a DSM320 sample at work, I will try to find some time, maybe I can figure it out.

      an ethereal log of the actual request from DSM320 to apache would be interesting...

    • -DK-

      -DK- - 2005-12-04

      I can try and do an ethereal log, but I don't know exactly how to set it up for that... I have only used that a couple of times and it wasn't for anything serious.

      I am wondering if there is another way to set up the apache server, I tried to figure that out but came up with nothing because I don't understand http that much and am learning as I go.


Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks