SourceForge has been redesigned. Learn more.

Segmentation Fault

  • Debasish

    Debasish - 2007-07-18

    When I run the mediatomb for notification, I get a segmentation Fault for arm architecture.
    I am using the latest mediatomb that is .10 version

    • Debasish

      Debasish - 2007-07-18

      I didnt face this problem for i386 architecture.
      I have added the proper values in config.xml file

    • Jin

      Jin - 2007-07-19

      OK, that's bad :>

      What are the last lines before the segfault that are printed in the console, could you paste the output please?

      What package are you using? Do you use our .deb binary, the .ipk's from nslu2-linux or did you compile it yourself?

      Is the segfault clearly reproducible (i.e. can you described the steps which lead to the segfault)?

      Last but not least, which kernel version do you have? I indeed have not thought about this, but if you use a binary with inotify support and try it on a kernel which does not provide this feature, it may indeed mean trouble :>

    • Debasish

      Debasish - 2007-07-19

      I compiled the mediatomb server.
      I am using linux 2.6.14, It has got inotify compiled with it as the same kernel when compiled with i386 architecture works.

      It gets segfault just before registering to inotify.

      If i dont have inotify in my config.xml then it works fine. I have checked the config.xml and entries for inotify works.
      Tried running with gdb but its shows no bt.
      Will try to solve it and if successfull will surely notify the mailing list

    • Debasish

      Debasish - 2007-07-19

      Segfault is everytime reproducible for arm board.

    • Jin

      Jin - 2007-07-20

      Hmm, interesting. It works on my arm hardware, so it must be something special about your setup. Can you set ulimit (assuming that you use bash) to a high value, so it produces a core file when it segfaults. Then try to load it with gdb, still no backtrace?

      Another question: some systems do not provide the inotify header, for those cases we use the header that we found in the inotify-tools package, maybe it does not properly work on your installation. Speaking of which... could you try the inotify-tools package?

      Does that package work for you? We use one function from this package and do the rest in a very similar way, so would be good if you could take a look and confirm how inotify-tools behave on your system.

  • Jon Hillyer

    Jon Hillyer - 2009-12-20

    Hi, I'm having a similar issue.
    I have installed MediaTomb on Debian (Buffalo Linkstation) but when I try and start it I get: the following (any ideas).

    MediaTomb UPnP Server version 0.11.0 -

    Copyright 2005-2008 Gena Batsyan, Sergey Bostandzhyan, Leonhard Wimmer.
    MediaTomb is free software, covered by the GNU General Public License version 2

    2009-12-20 12:09:59    INFO: Loading configuration from: /root/.mediatomb/config.xml
    2009-12-20 12:09:59    INFO: Checking configuration…
    2009-12-20 12:09:59    INFO: Setting filesystem import charset to ANSI_X3.4-1968
    2009-12-20 12:09:59    INFO: Setting metadata import charset to ANSI_X3.4-1968
    2009-12-20 12:09:59    INFO: Setting playlist charset to ANSI_X3.4-1968
    Segmentation fault

  • Jin

    Jin - 2009-12-20

    Nope, no ideas - you'd have to compile a version with debug output, preferably with debug symbols, maybe see that you get a coredump, otherwise there is not much I can say.

    Btw fix your charset settings, I guess locale is not setup on this device or is not setup for the particular user, so autodetectoin fails. This should not matter for the segfault though…

  • Jon Hillyer

    Jon Hillyer - 2009-12-21

    Thanks for this. I'll have a look at the charset settings.


Log in to post a comment.