Setting bit rate

Anonymous
2010-10-27
2013-05-30
  • Anonymous - 2010-10-27

    I am completely new to mediatomb. I am trying to make it work with AllShare application on Samsung Captivate phone. It seems like DLNA allplication on Captivate is bit picky. Using UPNP inspector from http://coherence.beebits.net/, I managed to fire queries again MiniDLNA where it works and against mediatomb where it does not work.

    Only important difference I have found out is in bitrate attribute of the generated xml response and it's rather large. MediaTomb sends bit rate as 393 where as MiniDLNA sends it 49234

    MediaTomb repsonse:
    <item id="29" parentID="21" restricted="1">
    <dc:title>sample_mpeg4.mp4</dc:title>
    <upnp:class>object.item.videoItem</upnp:class>
    <res protocolInfo="http-get:*:video/mp4:DLNA.ORG_OP=01;DLNA.ORG_CI=0" size="245779" duration="00:00:04.9" bitrate="393" sampleFrequency="32000" resolution="190x240" nrAudioChannels="1">http://192.168.1.2:49152/content/media/object_id/29/res_id/0/ext/file.mp4</res>
    </item>

    MiniDLNA response
    <item id="2$8$2" parentID="2$8" restricted="1" refID="64$2">
    <dc:title>sample_mpeg4</dc:title>
    <upnp:class>object.item.videoItem</upnp:class>
    <dc:date>2005-11-03T07:25:32</dc:date>
    <res size="245779" duration="0:00:04.992" bitrate="49234" sampleFrequency="32000" nrAudioChannels="2" resolution="190x240" protocolInfo="http-get:*:video/mp4:*">http://192.168.1.2:1900/MediaItems/20.mp4</res>
    </item>

     
  • Jin

    Jin - 2010-10-31

    I do not think the bitrate is the issue, what if you turn off the protocolInfo option in the config.xml, from what I see you set it to "yes", so the difference might be here: DLNA.ORG_OP=01;DLNA.ORG_CI=0

     

Log in to post a comment.