DSM-320 and files other than mpg and mp3 hang

lotso
2005-05-28
2013-05-30
  • lotso

    lotso - 2005-05-28

    Just got this installed and tried it out on a DSM-320. Didn't work at first, but after upgraded firmware from 1.02 to 10.5 it was able to contact the server.

    Playing files is OK too for MP3 and MPG files. However, playing WMV or MOV will hang the DSM.

    Playing AVI is very resource intensive. I'm not even sure if the cause is due to high Overhead or that There's a lot of logging being done by mediatomb on the command line (since it's not daemonised)

    I changed the config.php for the JOBS_PER_THREAD directive.

    What I've yet to try is the audioItem or (??) which I read in the help section of sourceforge.

     
    • Jin

      Jin - 2005-05-28

      Hi, the DSM topic has been discussed for a while.
      Take a look at this thread, regarding AVI playback: https://sourceforge.net/forum/forum.php?thread_id=1279907&forum_id=440750

      I think jason patched the UPnP SDK to fix this problem with the DSM-320, maybe he could share the patch with you?

      The DSM crashes are related to the upnp:class issue, I think some of it is covered in this thread: http://sourceforge.net/forum/forum.php?thread_id=1266601&forum_id=440750

      So you have to see what mimetype your mov/wmv files have (open a terminal and enter: file -i yourfile.mov", then make sure that this mimetype is being mapped to the upnp class "object.item.videoItem"

      good luck,
      Jin

       

Log in to post a comment.