Problem listing AVI files

Lord KiRon
  • Lord KiRon

    Lord KiRon - 2007-12-10

    I have IOmega 1TB (2X500) "Networked hard drive" (NAS) that comes with firmware 20.20 (latest at this moment)

    The device includes MediaTomb server.

    The problem is that when I try to access it using UPnP from Ziova/Zensonic Z500 player or their CS505 player ( ) it shows only .MPGs but not .AVIs in "Video" folder.
    It shows .AVIs fine from MS WMC UPnP server and from Tvonky UPnP server and Tversity UPnP server.

    Can someone advice what can be a reason ?

    • Lord KiRon

      Lord KiRon - 2007-12-10

      Forgot to mention one thing MediaTomb server in NAS identify itself as 0.9.0-inotify , which is kind of strange since if I am not mistaken inotify was added in 0.10.0 .
      Btw: unrelated but inotify does not there work anyway.

    • Jin

      Jin - 2007-12-10


      it's possible that the Zensonic has a similar problem like the D-Link DSM players - it wants the video/avi mimetype instead of video/x-msvideo; I do not remember for sure, but I think I was contacted by a Z500 user regarding that. You could make a simple test by choosing one of the AVI files in the Web UI, hitting the edit button and changing the mimetype to video/avi manually.

      The problem on the StorCenter is, that the config.xml is located in a place where it can not be accessed by the user, otherwise I would just tell you to add an appropriate extension to mimetype mapping to the config.xml so all avi files would be imported with the mimetype that your player is looking for.

      I am surprised that inotify is not working for you, it works on the 1TB 4x250 unit; the 0.9.0-inotify version is a special release that we made for Iomega, basically it's 0.9.0 + inotify functionality; 0.10.0 was not yet ready by that time and we had a tight schedule on the inotify feature.

      I can't promise anything, but I'll see if I can do something to help with this problem.

      Kind regards,

    • Lord KiRon

      Lord KiRon - 2007-12-10

      Thank you for your reply.
      Changing from "video/avi" type to "video/x-msvideo" helped - the file is shown (now I have to adit about 2K of files :) )
      Anyway at least it's a solution.

      Regarding inotify ...
      I tried to contact Iomega TS and instruct them what to do to reproduce but TS guys seems to disappear in the middle of the explanation (live chat) , so here are the steps :

      1. I run "Descovery tool Pro".

      2. Select the NAS drive and click "manage" - IE window pop up

      3. I enter the password I assigned to the NAS and in the "tree" on left click on "Applications"->"Mediaserver"
      It's enabled , so I click on "Media Setup" - new window pop up

      4. In new window I click on "FileSystem" and go to the path I want to share thru UPnP

      5. Then I click on 2nd plus sign (add to autoscan"

      6.Select "Scan Mode" to be Inotify , all others does not matter and press "Set"
      And as result got message "Unable to initialize inotify!"

    • Jin

      Jin - 2007-12-10

      From what I know (I think Leo tried it), it works on our 1TB Quad units. You should be able to use timed scans as a backup solution though.

      Regarding the mime-type... well yes, that's what the options in config.xml are for, so you can simply set a mapping, reimport the files and you're done. Adapting each file manually is not a real option... well, let's see if I can find out more.

    • Lord KiRon

      Lord KiRon - 2007-12-10

      Thanks I believe it works on Quad but it does not work on my new 2x500 unit, may be guys in Iomega messed something when compiled kernel :)

      As for config.xml ... I have no idea on how to access it , the linux folders are not accessible (and not visible as well) on my Storecenter 1T (2x500) :(

    • Jin

      Jin - 2007-12-10

      Well, that's exactly the problem - the config.xml is in a place where it can not be accessed. Unfortunately I can not look at my unit because I reflashed it with something else, but I hope that I can have a look at Leo's device, maybe we can come up with an idea on how we could help you.

    • Lord KiRon

      Lord KiRon - 2007-12-10

      Thanks again :)
      Btw somewhere on Iodata forums I saw some TS post mentioning that firmwares running in 2x500 and 4x256 are completely different.
      Btw: mine is v20.20 and it's the only one that exists for this unit.

    • Lord KiRon

      Lord KiRon - 2007-12-22

      Found another (probably configuration) problem with NAS:

      - it does not list .MP3 files as audio , .mp3 are ok but if you use capital characters ...

      Btw: any update on inotify issue on Storecenter 1T 2x500 ?

    • Jin

      Jin - 2007-12-22

      You mean if the mp3 extension is uppercase? uuh... probably it was compiled without libmagic support, thus mimetypes are defined by extension to mimetype mappings and those are indeed case sensitive.

      Sorry, but so far I have no news :(

    • Lord KiRon

      Lord KiRon - 2007-12-23

      Yep , MP3 in upper case :(

      Btw: found another problem - the UPnP server in StoreCenter - it completely ignores non english filenames (in my case Cyrillic) , the files are not get added and if you have a folder with Cyrillic characters in folder name - it's not get listed as well as sub-folders and files inside it.

    • Jin

      Jin - 2007-12-24

      Uhh.. that's bad. Probably something related to iconv, charsettings and conversion this should of course work if properly set up. ...ну ребята намудрили :Р

      I guess there are quite some improvements in the setup that need to be done. I already sent some suggestions on how things could be improved but I have no information if any firmware updates are planned.

      I'll ask the guys from OpenProtium if they plan adding support for the new Iomega units to their custom firmware, maybe that will become an option at some point.

    • Lord KiRon

      Lord KiRon - 2008-01-16

      Any chance for update on IOmega issues , because IOmega keep completely silent and their TS does not know anything.
      Короче мудаки они , но не поеду же я в штаты ещё раз чтоб сдавать ... :(

    • Jin

      Jin - 2008-01-16


      OK, have a look at this thread:

      If Вася can give more info on how to get telnet going, I could compile a custom MediaTomb version for you that will have support for everything that is needed. So far he did not yet reply...


Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks