how do you find mediatomb from ps3?

  • arminius

    arminius - 2009-10-02

    hey, I've got media tomb running on ubuntu, it's running in terminal and it's in my webbroswer, I've got both my ps3 and PC plugged into my NETGEAR router, that's my understanding of how the hardware is ment to be set up.
    but instructions on what to do on the ps3 side have been a bit vauge, I've scanned for media servor, and come up with nothing, I've entereted the http://ip adress that mediatomb is using on my pc, and still nothing.

    so what am I ment to do when I'm using the PS3?

  • Samuel Penn

    Samuel Penn - 2009-10-03

    Have you added <protocolInfo extend="yes"/> as per section 7.1.17 of the documentation? Apparently that's needed by the PS3, but I've no idea what effect not adding it has. Also, have you enabled allmulti on the network device (section 4.1 of the docs)? Have you tried a tool such as upnpscan to see if it's visible at all?

    I've actually got a similar problem. I have a perfectly functioning instance of MediaTomb running on an old server that my PS3 uses fine, but the new instance built on a new server appears invisible to the PS3. I have made the changes I suggested to arminius above.

    One difference is that the new instance is running in an OpenVZ environment (using veth devices), whilst the old instance is running in a Linux-VServers environment. I think I've made the necessary changes to allow UPNP to work correctly, so I'm not currently sure what else I'm missing. All servers are running Gentoo.

    Using upnpscan from a different server on the network I can see both instances of MediaTomb, so I assume that things are at least partially working.

    Anything else I may have forgotten?


  • Christian Samsel

    samuel, did you copy the config file? if so, make sure you change the uuid. if not the ps3 will think it sees the same server two times (e.g. over different interfaces) and disables one.
    second thing, make sure multicast ist working. that could be the issue with openvz.

  • Samuel Penn

    Samuel Penn - 2009-10-09

    I started with a fresh config file, and the uuid is definitely different. I've also tried shutting down the old server in case there was a conflict, but the new one doesn't appear.

    upnpscan is able to find it, so I believe that multicast is working. Both multicast and allmulti are enabled on the network device, and I'm using the network virtualisation that allows multicast to work (openvz gives two options, the other of which is more limited). So, as far as I can tell, the network is okay (otherwise upnpscan wouldn't see it either).



Log in to post a comment.