mediatomb configure problem

2008-11-30
2013-05-30
  • gary Grover

    gary Grover - 2008-11-30

    ./configure    failes with:
    configure: Will search for mysql config in /usr/local/mysql/bin
    configure: You specified /usr/local/mysql/bin for mysql_config
    configure: error: /usr/local/mysql/bin not found

    however  "/usr/local/mysql/bin" does exist and mysql_config is a member of "usr/local/mysql/bin"

    here is an abbreviated list of the library:

    root@abitbox:~# ls -l /usr/local/mysql/bin
    total 187652
    -rwxr-xr-x 1 mysql mysql    20086 2008-11-15 00:53 innochecksum*
    -rwxr-xr-x 1 mysql mysql     1424 2008-11-15 00:53 msql2mysql*
    -rwxr-xr-x 1 mysql mysql  1838374 2008-11-15 00:53 my_print_defaults*
    -rwxr-xr-x 1 mysql mysql  3037901 2008-11-15 00:53 myisam_ftdump*
    -rwxr-xr-x 1 mysql mysql  3351865 2008-11-15 00:53 myisamchk*
    -rwxr-xr-x 1 mysql mysql  3068852 2008-11-15 00:53 myisamlog*
    -rwxr-xr-x 1 mysql mysql  3128889 2008-11-15 00:53 myisampack*
    -rwxr-xr-x 1 mysql mysql  5011716 2008-11-15 00:53 mysql*
    -rwxr-xr-x 1 mysql mysql  4968126 2008-11-15 00:53 mysql_client_test*
    -rwxr-xr-x 1 mysql mysql 28659038 2008-11-15 00:53 mysql_client_test_embedded*
    -rwxr-xr-x 1 mysql mysql     6112 2008-11-15 00:53 mysql_config*
    -rwxr-xr-x 1 mysql mysql     3674 2008-11-15 00:53 mysql_convert_table_format*
    -rwxr-xr-x 1 mysql mysql     3245 2008-11-15 00:53 mysql_find_rows*
    -rwxr-xr-x 1 mysql mysql      483 2008-11-15 00:53 mysql_fix_extensions*
    -----sniip---snip---snip
    root@abitbox:~#                                                        

     
    • gary Grover

      gary Grover - 2008-11-30

      Info I forgot to include:

      here is the config instruction:

      root@abitbox:/home/gary/mediatomb# ./configure --with-mysql-cfg=/usr/local/mysql/bin

       
    • gary Grover

      gary Grover - 2008-12-01

      I believe the "configure" script is buggy

      2 Reason for that statement:
      A>
      With the error shown in my first post, adding the path to the PATH environment variable solved that problem;

      B>
      the configure parameter "--with-libdvdnav-cfg=/usr/bin/dvdnav-config" also caused the configure script to terminate early; with an error similar to error explained in my first post.  With this error, I added a symbolic link from
      "dvdnav_config" to "dvdnav-config". This prevented the script from terminating early, but did not correct the recognition that "libdvdnav" is installed.

      The version of mediatumb was retrieved from svn 11/11/2008

      I added a symbolic link to /usr/bin and the configure script completed successfully rather that terminating early.  However

       
    • Jin

      Jin - 2008-12-01

      The parameter expect the absolute path and name of the mysql_config, not just a path to where it is located.

      I.e. --with-mysql-cfg=/some/place/bin/mysql_config while you only provided /some/place/bin

      Kind regards,
      Jin

       
    • gary Grover

      gary Grover - 2008-12-03

      Thankyou for the information , Jin

      But I still think there may be a bug in the configure script.
      following are some excerpts form the console showing the basis for my thinking that there may be a bug

      -------------here is the command I ran-----------------
      gary@abitbox:~/mediatomb$ ./configure --with-libdvdnav-cfg=/usr/bin/dvdnav-config

      ------------Here is the result, note that libdvdnav is listed as missing.
      CONFIGURATION SUMMARY ----

      sqlite3               : missing
      mysql                 : yes
      libjs                 : missing
      libmagic              : yes
      inotify               : yes
      libexif               : yes
      id3lib                : disabled
      taglib                : yes
      libmp4v2              : yes
      libdvdnav             : missing
      ffmpeg                : yes
      ffmpegthumbnailer     : missing
      external transcoding  : yes
      curl                  : yes
      YouTube               : yes
      Weborama              : disabled
      SopCast               : disabled
      libextractor          : disabled
      db-autocreate         : yes

      -------------------This shows that dvdnav-config exists------------
      gary@abitbox:~/mediatomb$ ls -l /usr/bin/dvdn*
      -rwxr-xr-x 1 root root 1404 2008-11-22 00:12 /usr/bin/dvdnav-config*
      gary@abitbox:~/mediatomb$

      ------------------Shows where libdvdnav is located-------------
      gary@abitbox:~/mediatomb$ whereis libdvdnav
      libdvdnav: /usr/lib/libdvdnav.so /usr/lib/libdvdnav.la
      gary@abitbox:~/mediatomb$ 

      -----------------here is the version information --------------- root@abitbox:/home/gary/mediatomb# ./configure -V
      MediaTomb configure 0.12.0
      generated by GNU Autoconf 2.61

      Again, Thank you for the assistance

      Gary

       

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks