#58 MySQL db doesn't add items from a playlist

0.11.0
closed-fixed
Jin
Database (8)
5
2009-12-18
2009-12-09
Anonymous
No

Hi,

I've been using Mediatomb SVN for over year with a SQLite database without issue. It's great!

I've recently been testing Mediatomb SVN (2022) with a MySQL backend and it works well, certainly much fater than SQLite. However, items in .m3u playlists are not being added to the MySQL database. The playlist itself is being added but the items within the playlist are not being added to the playlist.

The only assistance I can offer is that the following ERROR shows up in the mediatomb.log file when scanning playlists.

ERROR: tried to add pure item with PLAYLIST_REF flag set

Like I said, this issue doesn't show up with SQLite but SQLite is much slower than MySQL.

Regards, Martin.

Discussion

  • Comment has been marked as spam. 
    Undo

    You can see all pending comments posted by this user  here

    Anonymous - 2009-12-09

    Oh dear! I'm seeing this problem with SQLite now as well. I wasn't having this problem with SVN 2018 but since upgrading to 2022 I see this problem.

     
  • Stephen Giles

    Stephen Giles - 2009-12-17

    I get exactaly the same bug in 2022 with SQlite. Playlists items won't add when using the
    "addCdsObject(item, playlistChain, UPNP_CLASS_PLAYLIST_CONTAINER)" in the playlists.js script.
    The container is created, but it is not populated with items.
    i've gone back to using the stock RPM of 0.11.0

     
  • Jin

    Jin - 2009-12-17
    • assigned_to: lww --> jin_eld
    • status: open --> pending-accepted
     
  • Jin

    Jin - 2009-12-17

    Can you please recheck with 2023? It should work now.

     
  • Comment has been marked as spam. 
    Undo

    You can see all pending comments posted by this user  here

    Anonymous - 2009-12-18
    • status: pending-accepted --> closed-fixed
     
  • Comment has been marked as spam. 
    Undo

    You can see all pending comments posted by this user  here

    Anonymous - 2009-12-18

    Hi,

    I've rebuilt SVN 2025 and the problem is fixed. Thanks very much.

    Regards, Martin.

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks