Centos 5 RPM's dont work :(

harmz s
2010-10-18
2012-12-11
  • harmz s

    harmz s - 2010-10-18

    hi

    im trying to install centos 5 rpms. they seem not too work

    root@ip-xx-xxx-xxx-xx # rpm -vi libmediainfo0-devel-0.                                                                                                                               7.26-1.i386.CentOS_4.rpm
    warning: libmediainfo0-devel-0.7.26-1.i386.CentOS_4.rpm: Header V3 DSA signature                                                                                                                               : NOKEY, key ID dfb2ef23
    error: Failed dependencies:
            libmediainfo0 = 0.7.26 is needed by libmediainfo0-devel-0.7.26-14.1.i386
            libzen0-devel >= 0.4.9 is needed by libmediainfo0-devel-0.7.26-14.1.i386

    I get "Failed dependencies" for all of them when i do this:

    rpm -vi libmediainfo0-devel-0.7.26-1.i386.CentOS_4.rpm
    rpm -vi libzen0-devel-0.4.10-1.i386.CentOS_4.rpm
    rpm -vi mediainfo-0.7.26-1.i386.CentOS_4.rpm
    rpm -vi mediainfo-gui-0.7.26-1.i386.CentOS_4.rpm

     
  • Jerome Martinez

    Jerome Martinez - 2010-10-18

    what is exactly the problem?
    There is currently no repository, so you need install them in order (first libzen, then libmediainfo, then mediainfo/mediainfo-gui. for devel, libzen-devel then libmediainfo).
    http://mediainfo.sourceforge.net/en/Download/CentOS

    you speak about CentOS but try with CentOS 4 packages, why?

    BTW, a repo will be installed soon, so it will be easier.

     
  • harmz s

    harmz s - 2010-10-18

    srry, i copied and pasted wrong. i tried for both centos 4 & 5

     
  • harmz s

    harmz s - 2010-10-18

    what is exactly the problem?
    There is currently no repository, so you need install them in order (first libzen, then libmediainfo, then mediainfo/mediainfo-gui. for devel, libzen-devel then libmediainfo).
    http://mediainfo.sourceforge.net/en/Download/CentOS

    I have done this in order and have tried various time, I still get the errors

    error: Failed dependencies:
            libmediainfo0 = 0.7.26 is needed by libmediainfo0-devel-0.7.26-14.1.i386
            libzen0-devel >= 0.4.9 is needed by libmediainfo0-devel-0.7.26-14.1.i386
           and so on............
    

    And i did go on http://mediainfo.sourceforge.net/en/Download/CentOS numerous times

    Still not working :~

     
  • Jerome Martinez

    Jerome Martinez - 2010-10-18

    why you log contains very old versions?
    I see you try to install the v0.7.26 devel package, have you installed v0.7.26 libmediainfo package?
    Why not using the latest version?

     
  • harmz s

    harmz s - 2010-10-18

    srry to confuse u, i copied & pasted wrong again

    heres my logs

    root@xxxxxxxxxxx [/home/xxxxxx/mediainfo]# rpm -vi libzen0-0.4.14-1.x86_64.CentOS_5.rpm
    warning: libzen0-0.4.14-1.x86_64.CentOS_5.rpm: Header V3 DSA signature: NOKEY, key ID dfb2ef23
    error: Failed dependencies:
            libc.so.6()(64bit) is needed by libzen0-0.4.14-11.1.x86_64
            libc.so.6(GLIBC_2.2.5)(64bit) is needed by libzen0-0.4.14-11.1.x86_64
            libgcc_s.so.1()(64bit) is needed by libzen0-0.4.14-11.1.x86_64
            libgcc_s.so.1(GCC_3.0)(64bit) is needed by libzen0-0.4.14-11.1.x86_64
            libgcc_s.so.1(GCC_4.0.0)(64bit) is needed by libzen0-0.4.14-11.1.x86_64
            libm.so.6()(64bit) is needed by libzen0-0.4.14-11.1.x86_64
            libm.so.6(GLIBC_2.2.5)(64bit) is needed by libzen0-0.4.14-11.1.x86_64
            libpthread.so.0()(64bit) is needed by libzen0-0.4.14-11.1.x86_64
            libpthread.so.0(GLIBC_2.2.5)(64bit) is needed by libzen0-0.4.14-11.1.x86_64
            libstdc++.so.6()(64bit) is needed by libzen0-0.4.14-11.1.x86_64
            libstdc++.so.6(CXXABI_1.3)(64bit) is needed by libzen0-0.4.14-11.1.x86_64
            libstdc++.so.6(GLIBCXX_3.4)(64bit) is needed by libzen0-0.4.14-11.1.x86_64
    
     
  • harmz s

    harmz s - 2010-10-18

    all packages failed to install, not matter how hard i try in order

     
  • harmz s

    harmz s - 2010-10-18

    I imagine you try to install x86_64 version on a i386 computer, right?

    No, my os is x86_64 i was trying the other one by mistake

     
  • harmz s

    harmz s - 2010-10-18

    my gcc-c++ is installed

    im getting these errors now

    warning: libzen0-0.4.14-1.i386.CentOS_5.rpm: Header V3 DSA signature: NOKEY, key ID dfb2ef23
    warning: libzen0-devel-0.4.14-1.i386.CentOS_5.rpm: Header V3 DSA signature: NOKEY, key ID dfb2ef23
    warning: libmediainfo0-0.7.35-1.i386.CentOS_5.rpm: Header V3 DSA signature: NOKEY, key ID dfb2ef23
    warning: libmediainfo0-devel-0.7.35-1.i386.CentOS_5.rpm: Header V3 DSA signature: NOKEY, key ID dfb2ef23
    
     
  • harmz s

    harmz s - 2010-10-18

    thanks :)

     
  • harmz s

    harmz s - 2010-10-18

    i cant find "mediainfo"  /usr/local/bin

    it should be /usr/local/bin/mediainfo

    its not even in /usr/bin

     
  • harmz s

    harmz s - 2010-10-18

    i have tried

    locate mediainfo

    no luck

     
  • Jerome Martinez

    Jerome Martinez - 2010-10-19

    what do you want to do???
    From the begining, you speak about devel packages. You installed devel (=development) packages!
    If you don't know what is a de devel package, don't install it…

    If you want the command line interface, install the command line interface package
    If you want the graphical user interface, install the graphical user interface package
    Install only the dependencies you need (libmediainfo0 and libzen0 if you don't develop software), as it is described when you try to install mediainfo CLI or GUI rpm, not devel packages.

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks