SourceForge has been redesigned. Learn more.

Building without GUI

John Nagle
  • John Nagle

    John Nagle - 2007-03-13

    I'd like to build just the command-line tools on a Fedore Core 6 server that doesn't have any of the Gnome stuff.  Is there some easy way to do this?  Thanks.

    • Brian Bruns

      Brian Bruns - 2007-03-16

      The configure script should detect that you don't have gnome and build without it.  You will need to have glib2 as it is used in the library and utilities.

    • John Nagle

      John Nagle - 2007-03-19

      Doesn't work.

      I'm starting from the release version, not the CVS version, and I'm trying to build on a Fedora Core 6 server.

      First, the build failed.  I found the bad declaration mentioned in Bug #1563144 that everybody hits, and patched the source code per the bug report.

      Then I had to install "glib2" and "glib2-devel". 

      Then the build failed by trying to invoking "yacc".  The requirements listing doesn't mention "yacc", and says that "bison" is optional.  But that's not correct; the "configure" script is trying to substitute "yacc" for Bison,
      and if you have neither, the build will fail.

      So I installed "bison", "bison-devel", and "flex".  The build got further, but still fails:

      /bin/sh ../../libtool --mode=link gcc  -g -O2 -DSQL   -o mdb-sql  mdb-sql.o ../libmdb/ ../sql/ -lglib-2.0   -lncurses -lreadline -lfl
      gcc -g -O2 -DSQL -o .libs/mdb-sql mdb-sql.o  ../libmdb/.libs/libmdb -lm ../sql/.libs/libmdbsql -lglib-2.0 -lncurses -lreadline -lfl -Wl,--rpath -Wl,/usr/local/lib
      ../sql/.libs/libmdbsql: undefined reference to `yylex'
      ../sql/.libs/libmdbsql: undefined reference to `yyerror'

      It looks like "src/sql/lex.yy.c" did get generated, but was never compiled.

      Has anyone ever successfully built this thing in recent years?

      • Stefan Lasiewski

        /bin/sh ../../libtool --mode=link gcc -g -O2 -DSQL -o mdb-sql mdb-sql.o ../libmdb/ ../sql/ -lglib-2.0 -lncurses -lreadline -lfl
        gcc -g -O2 -DSQL -o .libs/mdb-sql mdb-sql.o ../libmdb/.libs/libmdb -lm ../sql/.libs/libmdbsql -lglib-2.0 -lncurses -lreadline -lfl -Wl,--rpath -Wl,/usr/local/lib
        ../sql/.libs/libmdbsql: undefined reference to `yylex'
        ../sql/.libs/libmdbsql: undefined reference to `yyerror'

        I ran into this problem also. Ultimately, I solved this by installing the proper RPMS (Bison, Flex, etc).

        However, I also discovered that 'make clean' and 'make dist-clean' aren't removing everything. The workaround is to delete the build directory, and 'tar xf mdbtools-0.6pre1.tar.gz' again. I got stuck on this for hours... arg.


Log in to post a comment.