JAGS 3.4.0 LAPACK Compiling Error

  • Eric Kaufmann

    Eric Kaufmann - 2014-03-26

    I am trying to compile JAGS 3.4.0 on Centos 6.4. I keep getting the following error.

    configure: error: "You need to install the LAPACK library"

    The LAPACK library is not installed in the default location. So I have tried to compile with the following syntax.

    LDFLAGS="-L/cm/shared/apps/lapack/gcc/64/3.3.0" ./configure --libdir=/cm/shared/apps/jags/gcc/3.4.0/

    I have also tried several other variations, but still get the LAPACK error.

  • Martyn Plummer

    Martyn Plummer - 2014-03-27

    To find out what happened, you need to look in the config.log file.

    One possibility is that you have compiled and installed a recent version of lapack from the source at netlib.org. Recent versions create a library librefblas instead of libblas but the JAGS configure script has not been updated to cover this possibility.

    The solution then is to add the option --blas=-lrefblas to configure. You also need to ensure that blas and lapack are compiled with the flag -fPIC if you are doing it by hand (by editing make.inc).

    I should also remind you that RPMS of JAGS are available for CentOS



Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks