Does OS X Amiga emulation work?

Greg
2003-01-23
2003-01-25
  • Greg
    Greg
    2003-01-23

    I don't know who is supporting the Amiga UAE project but there wasn't much documentation included with the download. I downloaded the recent Dec. 29,2002 binary for Mac OS X , I placed a valid kickstart 1.3 rom in the same directory along with WB 1.3, I doulble clicked the MaxUAE.app and all I get is a console that starts out OK the it gets stuck in a loop of My Amiga did something stupid : illegal operation messages, right after a solid white window opens up. If I let the emulator continue to run sometimes the window turns black and it captures the mouse but that's about as far as it goes before I have to "force quit" the application.
    What gives? Anybody got any suggestions? I am trying to run UAE on Mac OSX 10.2.3 on a TI PB 800 Mhz DVI .
    Thanks!

     
    • Jonatin
      Jonatin
      2003-01-24

      As a matter of fact, Amiga emulation does work on MOSX.

      And it _is_ a beta, so there wasn't much documentation, because most is already in the UAE documentation, which was included.

      Here's some things to look at off the top of my head:

      What was you kickstart's name?  (kick.rom?)  What was your workbench's name?  (df0.adf?)  Did you use a .uaerc file or did you just open MaxUAE?

      And, which version of _valid_ WB1.3 did you use?  I use the Cloanto AmigaForever version with a key, (v34.5) and it works, and I use the one I sucked off my old A500 and it works (also v34.5).  Every other ROM I've got works.  (37.175, 39.106, 40.068)  All of them were transferred from a real Amiga with transrom.

      The UAE docs detail the options you can include in a .uaerc file, then you can just drop your .uaerc file right on the app and it'll boot with that config.  Try making a WB13.uaerc, or use the games.uaerc that I attached to the "sound problems" bug report and see if that doesn't clear up the problem.

       
    • Greg
      Greg
      2003-01-24

      I appreciate the help. But I must be thick or something. I am using the amiga forever 1.3 rom and WB1.3 from amiga forever disk.

      I had already renamed the  rom file to kick.rom & a wb1.3 file to df0.adf in the same folder as rom.key (whatever that is) and MaxUAE.app.

      I just tryed downloading the games31.uaerc file and after editting the line changing config_description=KickStart 3.1 to config_description=KickStart 1.3 & floppy0=./df0.adf
      I get the same result. I get two windows one is a console window and one is entitled"UAE- Main window". The main window starts out white and turns black. It covers the console window so that I can't read the error messages at first. Later the UAE- Log window comes to front and says" Your Amiga program just did something terribly stupid
      illegal instruction: 4e2b at 6102466f"
      The windows steal the cursor when clikcked on but all I get is a wait pointer ("spinning beachball") and I can't access menus.
      Do I have to reconfigure or remake the executable. As I prevously just downloaded the .dmg file and I am using the binary MaxUAE.app as is.

      Again I appreciate the help. Eventually I want to get my old Amiga 2000 software running on my PowerBook. Thanks!

       
      • Jonatin
        Jonatin
        2003-01-25

        Hmm, if the main window is covering the log window when you are using the games.uaerc file, then it's definately not reading the prefs at all.  That file specifies a native-size amiga window about 360x280, which shouldn't cover much.

        Did you drop the games.uaerc on MaxUAE?  Quit the program if it's running, then just drop the .uaerc file on the app.  It should tell you :

            Drop: config file= /yourpath/games.uaerc
            CFG = /yourpath/games.uaerc

        in the first few lines if it is using the dropped file.  Otherwise you will get something like :

            EXE = /yourpath/MaxUAE.app/Contents/MacOS/MaxUAE
            Changing working directory to: /yourpath/ (EXE)

        That pretty much means you double-clicked the icon and it's using the built-in defaults...

        Even when it works WB 1.3 will still tell you about an illegal instruction 4e7b but it's located at 00fc0564.  Thats normal.

        Try _not_ putting in a "floppy0=" line and renaming your ADF file to something like wb13.adf.  Then see if you get the Amiga ROM screen (with the hand holding a disk) you can use the Disks menu to insert the disk...

        From the location of the illegal instruction you got it sounds like the disk could also be corrupt, that's an address in RAM, not the ROM, but if it's an AmigaForever disk right off the CD then it really should work.

         
    • Greg
      Greg
      2003-01-25

      Jonatin,
      Hey I made progress! I reviewed the .uaerc file and added the line "kickstart_key_file=./rom.key". After dropping this file on the MaxUAE executable everything worked and I got to the Workbench 1.3 normal looking desktop. Evidently it wasn't finding Clanto's encrypted kickstart rom without this parameter.
      Everything appeared to be fine as far as text windows, cli's and shells. However when I ran the boing demo, the demo crashed immediately after flashing a quick grid on the desktop. I probably need to mess with the config file awhile to see what will work.
      Thankyou for your help! Now all I have to do is try to get Amiga explorer connected to my old Amiga 2000 through a null modem cable and transfer the old applications and games.
      Any info you could provide about special config file settings would be appreciated.
      Thanks again!

       
      • Jonatin
        Jonatin
        2003-01-25

        Digitalbiker,

        Congrats, sometimes it can be a real bear getting things going, but once you get the hang of it its pretty easy. 

        I'd say the most likely candidates for crashes are the blitter settings.

        If you get the "warning program does not wait for blitter" in the log window, set the "cpu_speed=" to something higer than 4, but less than 8.  (Just keep bumping it up until you don't get the warning any more)  This is especially important for games that do lots of custom chip hardware banging.

        Most of the really old games are sensitive to the RAM settings.  To duplicate an A500 use chipmem_size=2.  Set all other mem sizes to 0, if you try using fastram it'll likely crash.  If you _need_ expansion RAM (like for The Lemmings) set the bogomem_size=2 (or 4).  Bogomem is the RAM that the A500 had in the trapdoor.  (I didn't name it...)  Fastram is the Zorro II memory, which most old Amigas didn't have, and some games seem to HATE Zorro2 mem.

        If it's still crashing, use 24-bit addressing.

        Finally, my system is too old to really do sound well (with a decent framerate) so I set the sound to interrupts only if the program crashes with sound set to none, but your mileage may vary, it depends on how much the game/demo bangs the custom hardware.

        I'm investigating the framerate, as far as I can tell on my system setting it to any given value doesn't seem to do much of anything.  I've got that on my todo for beta 3, beta 2 I'm working just on getting the f-ing mouse working right.

        Good luck with the transfer, I had to use Term to upload everything to ZTerm and my poor A1200 couldn't really push more than 38400bps, so it took foooorreeeevvverrrrrr...