As far as I can see otherwise we will run into hard-to-reproduce problems when changing the build system.
How does my Linux system deal with this problem? Every time I test a new version of maxima there it automatically recreates the right files without even requiring me to use a new version number for my new maxima.
A timestamp that tests if the files are newer than the installation?

Kind regards,

   Gunter.



On 28. April 2014 16:42:06 MESZ, Martin Kraska <kraska@fh-brandenburg.de> wrote:

I repeat the proposal to specify version-specific user dirs, e.g. by changing line 31 in maxima.bat to

 

if "%MAXIMA_USERDIR%" == "" set MAXIMA_USERDIR=%USERPROFILE%\maxima%version%

 

Access to the draw package from within SMath Studio didn’t work for Maxima newer than 5.31.1-1. Fortunately, the 5.33.0 installers by David work. Here is an example: http://en.smath.info/forum/yaf_postsm12832_Maxima.aspx#post12832

 

Best regards, Martin Kraska

 

Von: Gunter Königsmann [mailto:gunter@peterpall.de]
Gesendet: Montag, 28. April 2014 11:28
An: Evgeniy Maevskiy; maxima-discuss@lists.sourceforge.net
Betreff: Re: [Maxima-discuss] Windows package, was: Maxima 5.33.0 release

 

I don't know if that is related. But I had the opposite problem: after installing 5.33.0.1 draw worked. After downgrading to the official version it stopped to work.
The Fix was: deleting everything in maxima_userdir.

Perhaps installing the new installer hybritized something there.

 

On 6. April 2014 19:31:27 MESZ, Evgeniy Maevskiy <emaevskiy@e-math.ru> wrote:

Hello, List!

On my Windows XP SP3 I have the next problem with Maxima-5.33.0.1,
package draw:

load("draw");

output:

;    - Source file
;      /Maxima-5.33.0.1/share/maxima/5.33.0/share/draw/grcommon.lisp and
;      binary file
;      D:/Maxima-5.33.0.1/user/binary/binary-gcl/share/draw/grcommon.o not
;      found, not loading.
loadfile: failed to load
D:/Maxima-5.33.0.1/share/maxima/5.33.0/share/draw/draw.lisp
  -- an error. To debug this try: debugmode(true);


06.04.2014 3:31, David Billinghurst пишет:

 On 5/04/2014 10:57 AM, David Billinghurst wrote:

 On 5/04/2014 5:52 AM, Robert Dodier wrote:

 On 2014-04-04, David Billinghurst <dbmaxima@gmail.com> wrote:

 There is a new windows installer available at
http://billinghurst.customer.netspace.net.au/maxima-5.33.0.exe

 Thanks, David. For the record, I installed it on my Windows Vista
laptop and it mostly works except that it runs into an error
whenever the Lisp compiler is invoked -- something about CreateProgram
or something like that. That error is provoked several times during
the test suite.


OK.  There is a new windows installer
http://billinghurst.customer.netspace.net.au/maxima-5.33.0.1.exe

This is built the classic way.  I worked around the makeinfo problem
using a wrapper script that calls cygwin makeinfo.  Not pretty, but it
works for me right now.

Postscript plotting is still broken.


 



Maxima-discuss mailing list
Maxima-discuss@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/maxima-discuss




 



Maxima-discuss mailing list
Maxima-discuss@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/maxima-discuss


--
Diese Nachricht wurde von meinem Mobiltelefon mit Kaiten Mail gesendet.