#98 plot3d bug with clisp

closed
nobody
None
5
2002-08-28
2002-08-02
Raymond Toy
No

From a discussion on the maxima mailing list, the
following works with CMUCL but not Clisp. (Haven't
tried gcl)

(C1)
plot3d(realpart(sqrt(25-x^2-y^2)),[x,-5,5],[y,-5,5],[grid,50,50]);
2 2
Is y + x - 25 positive, negative, or zero?

neg;

*** - argument to MINUSP should be a real number:
#C(-24.999999999999993 1.2245007080411163E-14)

Discussion

  • Raymond Toy
    Raymond Toy
    2002-08-18

    • status: open --> closed
     
  • Raymond Toy
    Raymond Toy
    2002-08-18

    Logged In: YES
    user_id=28849

    I can't reproduce this bug anymore, so it's history.

     
  • Raymond Toy
    Raymond Toy
    2002-08-19

    • status: closed --> open
     
  • Raymond Toy
    Raymond Toy
    2002-08-19

    Logged In: YES
    user_id=28849

    I was mistaken. It fails on Solaris with Clisp 2.28.

    Reopen this bug.

     
  • Raymond Toy
    Raymond Toy
    2002-08-26

    Logged In: YES
    user_id=28849

    I think this is related to the following bug with maxima and
    clisp on Solaris:

    (C1) (-5.0)^2;

    *** - argument to MINUSP should be a real number:
    #C(24.999999999999996 -6.122503540205582E-15)

    Got to find out how maxima is computing this to see.

     
  • Raymond Toy
    Raymond Toy
    2002-08-28

    Logged In: YES
    user_id=28849

    This is actually a bug in Clisp wherein (expt -5.0 2.0) was
    returning a complex number instead of a real. This has now
    been fixed in Clisp CVS.

     
  • Raymond Toy
    Raymond Toy
    2002-08-28

    • status: open --> closed