#1380 2^239-1 does not factorize properly

closed
nobody
Lisp Core (471)
5
2008-04-19
2008-03-31
Anonymous
No

I TYPED:
:lisp (factor (factor (- (expt 2 239) 1)));

RESULT:
((MTIMES SIMP FACTORED) 479 1913 5737 168048109206150821918223503032486170915673848376760773023074113)

EXPECTED:
((MTIMES SIMP FACTORED)479 1913 5737 176383 134000609 7110008717824458123105014279253754096863768062879)

E-MAIL:
irdaqramo@gmail.com

Discussion

  • Logged In: YES
    user_id=1179910
    Originator: NO

    This working as intended.

    The simplification routines in maxima sometimes factor integers. For obvious reasons, factoring large integers is disabled by default. This is controlled with the option variable intfaclim.

    This command gives correct factorization:

    :lisp (let (($intfaclim nil)) (factor (- (expt 2 239) 1)))

    This bug should be closed as invalid. I will leave it open for some time in case someone returns to see a reply.

    Andrej

     
  • Robert Dodier
    Robert Dodier
    2008-04-19

    • status: open --> closed
    • labels: --> Lisp Core
     
  • Robert Dodier
    Robert Dodier
    2008-04-19

    Logged In: YES
    user_id=501686
    Originator: NO

    Closing this report as "works for me". As explained by andrejv, the reported behavior is to be expected.