#1195 Required clisp version for maxima 5.12.0 is > 2.33.2

closed
nobody
5
2007-05-30
2007-05-18
Werner Hoch
No

Hi all,

the build fails with clisp version 2.33.3:

------error message------
Wrote file binary-clisp/generr.fas
; - Loading binary file "binary-clisp/generr.fas"
;; Loading file binary-clisp/generr.fas ...
;; Loaded file binary-clisp/generr.fas
; - Compiling source file
; "/usr/src/packages/BUILD/maxima-5.12.0/src/clmacs.lisp"
Compiling file /usr/src/packages/BUILD/maxima-5.12.0/src/clmacs.lisp ...
*** - READ from
#<INPUT BUFFERED FILE-STREAM CHARACTER
#P"/usr/src/packages/BUILD/maxima-5.12.0/src/clmacs.lisp" @314>: #<PACKAGE CUSTOM> has no external symbol with name "*FLOATING-POINT-RATIONAL-CONTAGION-ANSI*"
The following functions were used but not defined:
CL-INFO::CAUSE-MAXIMA-INDEX-TO-LOAD
0 errors, 2 warnings
make[1]: *** [binary-clisp/maxima.mem] Error 1
make[1]: Leaving directory `/usr/src/packages/BUILD/maxima-5.12.0/src'
make: *** [all-recursive] Error 1
-------------

It seems that the "FLOATING-POINT-RATIONAL-CONTAGION-ANSI" value was introduced later in clisp (see Changelog):
http://clisp.cvs.sourceforge.net/clisp/clisp/src/ChangeLog?revision=1.5517&view=markup

Changes between maxima 5.11.0 and 5.12.0:
http://maxima.cvs.sourceforge.net/maxima/maxima/src/clmacs.lisp?r1=text&r2=text&tr1=1.32&tr2=1.22&view=diff&diff_format=l

It would be nice if the requirement sections in could be updated:
file README.lisps
and the FAQ:
http://maxima.sourceforge.net/faq/faq.html#Lisp1

Regards
Werner

Discussion

  • Robert Dodier

    Robert Dodier - 2007-05-30
    • status: open --> closed
     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks