#1143 Load failed for affine.lisp

closed
nobody
5
2009-11-08
2007-03-02
Anonymous
No

The command load(affine) fails:

(%i1) load(affine);
; - Binary file /usr/local/share/maxima/5.11.0/share/affine/binary-clisp/sloop.fas is old or does not exist.
; Compile (and load) source file /usr/local/share/maxima/5.11.0/share/affine/sloop.lisp instead? y
y
; - Should I bother you if this happens again? y
y
0 errors, 0 warnings
Load failed for /usr/local/share/maxima/5.11.0/share/affine/affine.lisp
-- an error. To debug this try debugmode(true);
(%i2)

-------------------Build informations-----------------
Maxima version: 5.11.0
Maxima build date: 11:14 3/2/2007
host type: i686-pc-linux-gnu
lisp-implementation-type: CLISP
lisp-implementation-version: 2.39 (2006-07-16) (built 3363335052) (memory 3381819320)
------------------------------------------------------

Discussion

  • Robert Dodier

    Robert Dodier - 2007-03-03

    Logged In: YES
    user_id=501686
    Originator: NO

    To the person who submitted this item: please leave your email address or make a SF login or something so we can communicate with you.

    I believe the reason affine fails is that load(affine) attempts to write compiler output into the Maxima installation directory. This is a bug, and we are debating how to resolve it.

    In the meantime, a workaround: In response to any question about compiling, respond "n", and if it asks about loading the source file, respond "y". Does that help?

     
  • guno

    guno - 2007-03-18

    Logged In: YES
    user_id=1709853
    Originator: NO

    the former postin means:
    look at bug 1651508: load(affine) fails
    guenter

     
  • Josh

    Josh - 2007-05-25

    Logged In: YES
    user_id=1801269
    Originator: NO

    I have the same problem. Both in 5.12.0 and in the most recent cvs version.
    Using common lisp. robert_dodier's suggestion did not work for me.
    Any ideas?

     
  • Dieter Kaiser

    Dieter Kaiser - 2009-11-08

    I think this bug report is out of date. We have Maxima 5.19post and had some work on the loading of packages. Similar bug reports have been closed already too.
    Closing this bug report as out of date.
    Dieter Kaiser

     
  • Dieter Kaiser

    Dieter Kaiser - 2009-11-08
    • status: open --> closed
     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks