I did use sudo--here are the shell command and the install output:

sudo python setup.py install

============================================================================
BUILDING MATPLOTLIB
            matplotlib: 0.98.5.2
                python: 2.5.2 (r252:60911, Oct  5 2008, 19:29:17)  [GCC
                        4.3.2]
              platform: linux2

REQUIRED DEPENDENCIES
                 numpy: 1.2.1
             freetype2: 9.18.3

OPTIONAL BACKEND DEPENDENCIES
                libpng: 1.2.27
               Tkinter: Tkinter: 50704, Tk: 8.4, Tcl: 8.4
              wxPython: no
                        * wxPython not found
                  Gtk+: gtk+: 2.14.4, glib: 2.18.2, pygtk: 2.13.0,
                        pygobject: 2.15.3
       Mac OS X native: no
                    Qt: no
                   Qt4: no
                 Cairo: 1.4.12

OPTIONAL DATE/TIMEZONE DEPENDENCIES
              datetime: present, version unknown
              dateutil: 1.4
                  pytz: 2008b

OPTIONAL USETEX DEPENDENCIES
                dvipng: 1.11
           ghostscript: 8.63
                 latex: 3.141592
               pdftops: 3.00

[Edit setup.cfg to suppress the above messages]
============================================================================
pymods ['pylab']
packages ['matplotlib', 'matplotlib.backends', 'matplotlib.projections', 'mpl_toolkits', 'matplotlib.numerix', 'matplotlib.numerix.mlab', 'matplotlib.numerix.ma', 'matplotlib.numerix.npyma', 'matplotlib.numerix.linear_algebra', 'matplotlib.numerix.random_array', 'matplotlib.numerix.fft', 'matplotlib.delaunay']
running install
running build
running build_py
copying lib/matplotlib/mpl-data/matplotlibrc -> build/lib.linux-x86_64-2.5/matplotlib/mpl-data
copying lib/matplotlib/mpl-data/matplotlib.conf -> build/lib.linux-x86_64-2.5/matplotlib/mpl-data
running build_ext
running install_lib
copying build/lib.linux-x86_64-2.5/mpl_toolkits/gtktools.py -> /usr/lib/python2.5/site-packages/mpl_toolkits
error: /usr/lib/python2.5/site-
packages/mpl_toolkits/gtktools.py: No such file or directory




On Fri, Jan 9, 2009 at 10:02 PM, John Hunter <jdh2358@gmail.com> wrote:
On Fri, Jan 9, 2009 at 10:56 AM, Hani Nakhoul <nakhoul@gmail.com> wrote:
> Hi all,
> I'm having trouble compiling Matplotlib (0.98.5.2) on Ubuntu Intrepid (Linux
> ubuntu 2.6.27-9-generic #1 SMP Thu Nov 20 22:15:32 UTC 2008 x86_64
> GNU/Linux). Running install ultimately gives

I would like to see the shell command you type for the install (did
you use sudo?) and the complete output.  You showed us the build
output, which looks fine, so please post the *entire* install command
and output.

JDH