On Wed, Apr 18, 2012 at 10:00 AM, Werner F. Bruhin <werner.bruhin@free.fr> wrote:
On 18/02/2010 22:41, Werner F. Bruhin wrote:
> Using numpy with "/arch nosse" solved the issue.
>
> Probably OT here, but does anyone know if numpy will in the future be
> able to dynamically switch on/off the SSEx support?
I am running again into crashes with matplotlib/numpy on Windows XP
running on AMD Athlon type machiens.

I distribute the application with py2exe, so on my machine I install
numpy with "/arch nosse".

This works on a test machine with my older program version which uses
Python 2.5, matplotlib 0.99 and numpy 1.0.4, now with my newer stuff I
use Python 2.6, still matplotlib 0.99 and numpy 1.3 (as there is no
1.0.4 for Py 2.6), with this configuration my program crashes on the
Athlon CPU.

Tried upgrading to 1.4.1 and 1.5.1 of numpy (still using /arch nosse)
but still see the same crash with an error code of "0xc000001d".

Short term a 1.0.4 for Python 2.6 would be an o.k. work around, but I
really like to get a something better.  Would an upgrade of matplotlib help?

Werner


I think we have some confusion for version numbers.  There was never a version 1.0.4 of mpl.  There was a version 1.0.1, but not 1.0.4.  Also, you mention numpy version 1.0.4, I certainly would hope you are referring to numpy 1.4.0.  Could you please double-check your version numbers so we can get a better idea of what is happening?

Thanks,
Ben Root