One more datapoint--I am becoming suspicious that this could be an arch problem.  A colleague was able to build from source under cygwin on his rather old laptop.  However, another colleague and myself have rather new computers and both failed (with different errors in the verbose mode).  I just tried following Michael's build instructions (incidentally, could his last additions to setup.py be checked in to svn, along with a profile25.bat file?) on an old windows box that we have lying around here and it also worked well and I was able to run the embedding_in_wx4.py example without any problems.

The computer that I've been having all of the problems on also was relatively clean--so, there are only two things I can think of--either some bizarre clash with the version of numpy that I built from source off of svn (which passed all of its tests, so I doubt it), or an arch dependence.  I have an intel quad and my colleage has a duo, so perhaps there's a problem with computers with multiple processors?  I will check the numpy issue later today.

Thanks again,
William

On 8/2/07, william ratcliff <william.ratcliff@gmail.com> wrote:
Oh--sorry I didn't read carefully--I don't need to install from source if there is a binary of the current svn version.

Thanks!!

William


On 8/2/07, william ratcliff <william.ratcliff@gmail.com> wrote:
One of my colleagues, Paul Kienzle has made a number of additions to matplotlib for interacting with artists.  I need to use some of those additions--which are not included in the stable release.  Paul's on vacation, so I am trying to start from source.

Thanks,
William


On 8/2/07, John Hunter < jdh2358@gmail.com> wrote:
On 8/2/07, william ratcliff <william.ratcliff@gmail.com> wrote:
> Thanks again for all your work on this.  I moved my old minGW and installed
> MinGW-5.1.3 , and was already running the others--except numpy, I have the
> latest version from svn, which I compiled and built fine after building
> atlas.  I checked out matplotlib from svn and did the same as you
> --I didn't try using the importlib batch file--I have a libpython25.a--so,
> after changing the profile24.bat to profile25.bat with appropriate path
> changes and your modifications to setup.py, I built it.  I then installed
> it--no problems yet.  I then tried to use it with embedding_in_wx4.py and
> python crashes and burns.  I find that it crashes with the same LazyValue
> error. Something similar happened to one of my colleagues who tried building
> with visual studio instead of mingw.  He's given up and is now running it on
> his Mac.  Sadly, I don't have that option.  Does anyone else have any ideas?

Charlie Moad does our win32 builds for releases -- Charlie if you get
a minute could you see if your build pipeline is still working OK with
the recent svn changes, and if so take pity on poor William and send
him an installer?

Or is there some reason you *need* to be building from src William?

Thanks,
JDH