Hi all,

I've successfully used version 0.52. Yesterday I installed v0.64 on my RH9 linux box. The build and install went OK. However, when I try to play with it, I get:

The import of the numeric version of the _transforms module, _nc_transforms, failed.
This is either because numeric was unavailable when matplotlib was compiled,
or because a dependency of _nc_transforms could not be satisfied.
If it appears that _nc_transforms was not built,  make sure you have a working copy of
numeric and then re-install matplotlib. Otherwise, the following traceback gives more details:

Traceback (most recent call last):
....
    from matplotlib.backends.backend_wxagg import FigureCanvasWxAgg as FigureCanvas
  File "/usr/local/lib/python2.3/site-packages/matplotlib/backends/__init__.py", line 20, in ?
    globals(),locals(),[backend_name])
  File "/usr/local/lib/python2.3/site-packages/matplotlib/backends/backend_wxagg.py", line 18, in ?
    from backend_agg import FigureCanvasAgg
  File "/usr/local/lib/python2.3/site-packages/matplotlib/backends/backend_agg.py", line 78, in ?
    from matplotlib.backend_bases import RendererBase,\
  File "/usr/local/lib/python2.3/site-packages/matplotlib/backend_bases.py", line 13, in ?
    from patches import Rectangle
  File "/usr/local/lib/python2.3/site-packages/matplotlib/patches.py", line 5, in ?
    from artist import Artist
  File "/usr/local/lib/python2.3/site-packages/matplotlib/artist.py", line 4, in ?
    from transforms import identity_transform
  File "/usr/local/lib/python2.3/site-packages/matplotlib/transforms.py", line 188, in ?
    from _transforms import Value, Point, Interval, Bbox, Affine
  File "/usr/local/lib/python2.3/site-packages/matplotlib/_transforms.py", line 11, in ?
    from matplotlib._nc_transforms import *
ImportError: /usr/local/lib/python2.3/site-packages/matplotlib/_nc_transforms.so: undefined symbol: _ZNSs4_Rep20_S_empty_rep_storageE

I tried many things in the setupext.py. Freetype is correctly installed and Numeric is in /opt/Numeric23.1. I added this to the script.... because the way it appends include/lib path seems a little buggy to me.

def add_ft2font_flags(module):
    'Add the module flags to build extensions which use gd'
    ....
    module.include_dirs.append('/usr/local/include/freetype2/freetype')
    ....

and
def add_agg_flags(module):
    'Add the module flags to build extensions which use agg'

    # before adding the freetype flags since -z comes later
    module.libraries.append('png')
    module.libraries.append('z')
    add_base_flags(module)
    module.include_dirs.extend(['src','agg22/include', '.'])
    module.include_dirs.append('/opt/Numeric-23.1/Include')
    # put these later for correct link order
    module.libraries.extend(['stdc++', 'm'])


I also tried other things. I still get the same error message. I'm stuck ! Has anyone encoutered this problem ?
solved it ? Shall i install a newer version of Numeric ? In an other place than /opt ?

Any help would be geatly appreciated !

Christophe