I installed EPD and now would like to install the latest version of matplotlib so I can try out the new CocoaAgg background.  I can download the binary mpkg from sourceforge, but it won't work for me because my python version isn't the python from python.org.  Can someone help me get this installed?

Mac OS 10.5.6
EPD with Py2.5 (4.0.30002 ) -- http://www.enthought.com/epd