Tim: I don't have 10.6 yet, so I've never tried building there.  I suspect that it's a 32/64 bit library mismatch problem.  Since I believe OSX builds stuff 64 bit by default on OS X, my guess is you are using a 32 bit python, perhaps macpython?  If so, perhaps building geos with CFLAGS="-m32" will fix it.  Or, it could be that you have a 64 bit python and the lib was built 32 bit.

Maybe someone else with experience with 10.6 will chime in, I'm really just shooting in the dark here..



Thanks Jeff and Eric,

Problem is now (mostly) solved.

I was using 32bit Python 2.6.3 on OS X 10.5 - simply a python.org installation. A couple of days ago, with a bit of free time, I upgraded to OS X 10.6. Generally pretty smooth, but I suspect some of my Python changes got crushed as I had pointed /usr/bin/python* to my 2.6.3 install. After your emails, I checked and yes on 10.6, the compiler defaults to 64bit. So:

cd geos-2.2.3
export CFLAGS="-m32"
export GEOS_DIR=/usr/local
./configure --prefix=$GEOS_DIR
make
sudo make install

Another complete build but unfortunately same library reference problem.

So....decided to go down the MacPorts path. Many automated downloads later, I now have a successful Basemap install (yay!)
Many thanks to the folks who have contributed to MacPorts and interestingly geos 3.1.1 is installed.

Only present worry is that wxWidgets port is not building on 10.6 - yet to resolve that.

And FYI, to check whether you have a 64bit Python install:

192-168-1-3:basemap-0.99.4 tim$ python
Python 2.6.4 (r264:75706, Nov  6 2009, 18:14:21) 
[GCC 4.2.1 (Apple Inc. build 5646) (dot 1)] on darwin
Type "help", "copyright", "credits" or "license" for more information.
>>> import sys; print sys.maxint
9223372036854775807

if you get a smaller number, you have a 32bit interpreter

P.S. Should simpletest.py not be called 'hello_world.py' :-)

Tim Burgess