I am having troubles  getting matplotlib to install.  I have mac os X lion with Xcode 4.2.1 installed and  I have used git to get the latest version of matplotlib.  I am also running python 2.7.2 from the python.org site. The installation process was going fine based on the make.osx file supplied .  The only thing I had to do was add a symbolic link to map gcc-4.2 to gcc to get it to compile, the I hit the following problem:

So what do you mean precisely by "the installation process was going fine" if you hit that complile error? So it did't go fine AISI, no?

In file included from src/ft2font.cpp:3:
src/ft2font.h:16:22: error: ft2build.h: No such file or directory

AFAIR this means it did't find the freetype2 installation sources. Either it's some mistake in make.osx or you did one. Can't say anything emphatically at this stage. Normally the make.osx installs the freetype2 somewhere. 

src/ft2font.h:17:10: error: #include expects "FILENAME" or <FILENAME>

You could have a look which include that is. I don't have the sources here. 

Sorry for the slow reply. 

Friedrich