#23 error on cygwin build

developer
closed
5
2016-07-14
2012-10-03
flashpixx
No

Hello,
I try to build Atlas 3.10.0 on Windows Cygwin and get an error on "make install":

ATLAS install complete. Examine ATLAS/bin/<arch>/INSTALL_LOG/SUMMARY.LOG for details.
make[1]: Leaving directory `/cygdrive/c/Users/Administrator/Documents/library/atlas3.10.0-buildtmp'
make clean
make[1]: Entering directory `/cygdrive/c/Users/Administrator/Documents/library/atlas3.10.0-buildtmp'
rm -f *.o x* config?.out *core*
make[1]: Leaving directory `/cygdrive/c/Users/Administrator/Documents//library/atlas3.10.0-buildtmp'
657 [main] sh 536 exception::handle: Error while dumping state (probably corrupted stack)
scons: *** [library/buildatlas-3.10.0] Error -11

If I run "make" again, all parts are build and if I run "make install" again the library is installed to the prefix dir, so everything works fine, but only on the second install run

I don't know if this is an Atlas or Cygwin problem. I hope anybody can help me
Thanks a lot

Phil

Discussion

  • R. Clint Whaley

    R. Clint Whaley - 2016-07-14
    • status: open --> closed
    • assigned_to: R. Clint Whaley
    • Group: --> developer
     
  • R. Clint Whaley

    R. Clint Whaley - 2016-07-14

    Sorry for the extreme neglect. I have overwhelmed, and have not been able to provide support for some time. In order to get back to even, I am mass closing existing old support requests.

    If your support request involved the stable release, please try the new 3.10.3BETA release that you can find under the developer releases. That is the release that I have updated to work better on modern hardware, including MacOS and Windows. If you still have a problem with 3.10.3BETA, please open up a new ticket, and I will try to get it fixed before the official 3.10.3 release. Please note t
    he updated ATLAS/doc/atlas_install.pdf: the online document is still for 3.10.2,
    and will remain so until 3.10.3's official release.

    If your support request involved the developer release, I recommend waiting for 3.11.39 before reopening, as I am currently in the middle of a major rewrite. If the problem persists into .39, I definitely want to hear about it.

    Thank you, and I am very sorry about my responsiveness on support.

     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks