#72 configure won't accept netlib option

open
None
5
2010-10-19
2010-10-02
No

When I try to configure with this command:
../configure -Fa alg -fPIC --with-netlib-lapack=/home/ia3n/Libraries/lapack-3.1.1/lapack_LINUX.a
I get this error followed by the usage instructions:
ERROR around arg 10 (--with-netlib-lapack=/home/ia3n/Libraries/lapack-3.1.1/lapack_LINUX.a).

If I leave out the netlib part, it works fine.

Discussion

  • R. Clint Whaley

    R. Clint Whaley - 2010-10-19

    Yes, this option has been removed. There are several people who are advocating for its return; I have moved this to the feature request list, please post here the reason you don't want to use --with-netlib-lapack-tarfile, which is the newest way of doing this.

    Thanks,
    Clint

     
  • R. Clint Whaley

    R. Clint Whaley - 2010-10-19
    • assigned_to: nobody --> rwhaley
    • labels: 320139 -->
     
  • Comment has been marked as spam. 
    Undo

    You can see all pending comments posted by this user  here

    Anonymous - 2010-10-19

    Bringing back the old option will much welcomed by packagers building ATLAS for Linux distros.

     
  • Ian Goodfellow

    Ian Goodfellow - 2010-10-19

    I don't really care which option is supported but if you want people to quit asking about it you might want to remove the old option from INSTALL.TXT. I just grepped INSTALL.TXT for netlib so it was a long time before I saw the disclaimer at the top saying that INSTALL.TXT is out of date and to refer to the pdf instead.

     

Log in to post a comment.