#64 ATLAS and GCC 4.x versions and flags

Would_be_nice
closed
5
2007-08-14
2007-08-13
No

Hello,
I read through your gcc bugzilla report ( http://gcc.gnu.org/bugzilla/show_bug.cgi?id=27827 ) and was wondering, now that gcc 4.2.1 has been released, if there was a consensus on which version should be used because the main howto still looks like it says to avoid gcc 4.x? Is this still in limbo until the mac + 4.2 issues get resolved? Also, if you could point out which gcc flags are sane/appropriate for gcc 4.2.x I would also appreciate that greatly.
Thanks,
Benj

Discussion

  • R. Clint Whaley

    R. Clint Whaley - 2007-08-14
    • assigned_to: nobody --> rwhaley
    • status: open --> closed
     
  • R. Clint Whaley

    R. Clint Whaley - 2007-08-14

    Logged In: YES
    user_id=182470
    Originator: NO

    You should definitely use gcc 4.2, and if you use the 3.7 release, it should automatically suggest good gcc 4.2 flags. The 3.7 release is almost ready to become the new stable, so it is the only one I am really supporting at the moment . . . Even on the mac, where there has been some retreat in perf, I am still aiming for gcc 4.2 support . . .

    Cheers,
    Clint

     
  • Benj FitzPatrick

    Logged In: YES
    user_id=1866877
    Originator: YES

    Thanks Clint!

     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks