shared libraries not being built

Alan McKay
  • Alan McKay

    Alan McKay - 2013-09-04

    Hi folks,

    I run this from my build directory

    /data/src/ATLAS-3.10.1/configure --prefix=/data/binaries/${HH}/ATLAS-3.10.1 --shared

    and then I run all the subsequent make commands, but "make install" in the end informs me it cannot find the shared libraries. And sure enough they are not there.

    What am I don't wrong?


  • Alan McKay

    Alan McKay - 2013-09-04

    Oh I am trying to build R-3.0.1 with ATLAS and R is complaining.

    mkdir -p $PREFIX
    LDFLAGS="-L/data/binaries/solexa3/ATLAS-3.10.1/lib -lf77blas -latlas" ./configure --prefix=$PREFIX

    gcc -std=gnu99 -shared -fopenmp -L/data/binaries/solexa3/ATLAS-3.10.1/lib -lf77blas -latlas -o blas.o cmplxblas.o -lf77blas -latlas -lgfortran -lm # xerbla.o
    /usr/bin/ld: /data/binaries/solexa3/ATLAS-3.10.1/lib/libf77blas.a(xerbla.o): relocation R_X86_64_32S against `a local symbol' can not be used when making a shared object; recompile with -fPIC
    /data/binaries/solexa3/ATLAS-3.10.1/lib/libf77blas.a: could not read symbols: Bad value

    And funny thing is that when I read the ATLAS install doc it says that it supplies -fPIC automatically. And when I try to supply it myself I get an error with the ATLAS xconfig command.


Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.

No, thanks