Building ATLAS with Cygwin on Windows 7


    SHU-HONG LIN - 2013-08-15

    Hi, I am trying to install the most recent stable ATLAS (3.10.1) on 32-bit Windows 7. The required packages for Cygwin has already been installed. But the configuring step still returned the following error messages:

    make: *** No rule to make target `xconfig'. Stop.
    ./xconfig -d s /cygdrive/c/Python27/ATLAS/ATLAS-3.10.1/../ -d b /cygdrive/c/Python27/ATLAS/ATLAS-3.10.1
    /bin/sh: line 1: ./xconfig: No such file or directory
    xconfig exited with 127

    I tried adding flags like --prefix=/cygdrive/c/Python27/ATLAS/ATLAS-3.10.1/ -b 32 -V 192 -A 13 -D c -DPentiumCPS=3100. But nothing worked. Suggestions?

  • Ian Boardman

    Ian Boardman - 2013-09-23

    I'm also having trouble with the configure step. I have tried with 3.11.11 and some of the older stable packages. I get a complaint right after configure runs ./xprobe_comp:

    ./xprobe_comp -v 1 -o atlconf.txt -O 9 -A 27 -Si nof77 0 -V 448  -C if '/usr/bin/gfortran.exe' -b 64 -d b /cygdrive/c/sandbox/ATLAS/cygwin_build
    sh: -c: line 0: syntax error near unexpected token `('  <<<<NOTICE
    sh: -c: line 0: `find /usr/local/bin /usr/bin /cygdrive/c/Python27 /cygdrive/c/Python27/Scripts /cygdrive/c/Perl64/site/bin /cygdrive/c/Perl64/bin
    /cygdrive/c/Program\ Files/RA2HP /cygdrive/c/Windows/system32 /cygdrive/c/Windows /cygdrive/c/Windows/System32/Wbem /cygdrive/c/Windows/System32/WindowsPowerShell/v1.0
    /cygdrive/c/Program\ Files/ActivIdentity/ActivClient /cygdrive/c/Program\ Files\ (x86)/ActivIdentity/ActivClient /cygdrive/c/Program\ Files\ (x86)/Microsoft\ SQL\ 
    Server/90/Tools/binn /cygdrive/c/Program\ Files/Perforce /cygdrive/c/Program\ Files/SlikSvn/bin /cygdrive/c/Program\ Files/Microsoft/Web\ Platform\ Installer 
    /cygdrive/c/Program\ Files\ (x86)/Microsoft\ ASP.NET/ASP.NET\ Web\ Pages/v1.0 /cygdrive/c/Program\ Files\ (x86)/Windows\ Kits/8.0/Windows\ Performance\ Toolkit 
    /cygdrive/c/Program\ Files/Microsoft\ SQL\ Server/110/Tools/Binn /cygdrive/c/Program\ Files/TortoiseSVN/bin /cygdrive/c/Users/boardmai/AppData/Roaming/Python/Scripts 
    /cygdrive/c/Program\ Files\ (x86)/Process\ Utilities /usr/lib/lapack -maxdepth 1 -name '*gcc*' -exec ./xisgcc '{}' \; > /tmp/ta88.5 2>&1'

    [n.b. I split up the error message above to wrap it into a more narrow text area]

    The find command line can be found embedded in this binary tool. If I read this right, it is actually trying to run this command in the cygwin shell without escaping the parens in the argument string, i.e. "Program Files (x86)", etc. If I'm correct, this is pretty messed up, else, I'm just lost as to what's going on and what to do about it.

    Please advise. Thanks.

  • mholzel

    mholzel - 2014-05-26

    I had a similar problem. It boiled down to the fact that I had a mis-typed path in my Environmental Variables. I must have modified the Environmental Variables at one point, and one of the paths was changed from "C:\Program Files (x86)\Intel\iCLS Client" to "C:\Program Files (x86)\Intel\iCLSClient". But this was completely my error.

    I suspect the problem is that you need to modify one of the source files. Specifically, you probably just need to perform step 1) of these instructions:

    That being said, I still haven't managed to get a complete build of ATLAS, but this seems to fix those problems.


Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks