Index exceeds matrix dimension

  • Francois David

    Francois David - 2009-09-11

    Dear all,
    I am struggling with matcont tutorials. I have tried 3 of them (Meijer,2009 and Dhooge et al, 2006 a,b). I have exactly the same bug with all of them. When computing the P_O curves, there is no problem but when starting computing continuation from the equilibrium (through Type:Initial point: Equilibrium and then Compute Backward or Forward), I have the same message error : "Index exceeds matrix dimension".
    I use the latest version of matlab2009b with the toolbox smbolic and the latest version of matcont.
    Has anyone ever met this problem or would anyone know the origin?
    Thanks, Sincerely.

    • KLAY

      KLAY - 2009-09-11

      I had those problems, but have no solution, and no further observations.

  • Govaerts

    Govaerts - 2009-09-15

    I am not aware of this problem.  In fact, this is my favourite way to start the continuation of equilibria. Have you selected the last point of the computed orbit and declared it to be an equilibrium? And what happens if you directly type in the coordinates of an equilibrium point? Which example did you use?

    Willy Govaerts

  • Francois David

    Francois David - 2009-09-16

    Thanks for your reply. To answer your points, yes I selected the last point of the computed orbit and declared it as an equilibrium. I have the same problem if I declare the coordinates of the equilibrium point. I have used the lorenz84 model and the Fast Morris-Lecar model.
    I progressed slightly since my last post, but I noticed that if I use numerically computed derivatives, I could complete the tutorial Meijer but not if I use the symbolically computed derivatives. I conclude that the way the symbolically derivatives are estimated, is the source of  the problems, but I am still stuck there for the moment.

  • Ioannis Tigkas

    Ioannis Tigkas - 2009-09-16

    I have experienced the same problem few years ago, but I do not really remember how i solved it. it seems like a bug so why don't you try to either:
    make a new file with a different name and start everything from the beginning or uninstall matcont and re-install a fresh copy and start again from there….

    Anyway, numerically solving the derivatives seems usually more stable especially for high-order systems…

  • Morton

    Morton - 2012-05-17

    Hi colleagues,

    I have the same issue. Although I re-installed the matcont package, the problem still remains.

    Has any one found a permanent solution to this?

    Thanks a lot

  • Gyanadutta

    Gyanadutta - 2012-12-11

    I am also facing the same problem "index exceeds matrix dimension"  when computing the EP-EP curve.. this is persisting for all problems I tried including Lorentz of Meijer… 

  • efi12

    efi12 - 2013-02-23

    Hi guys,

    I had the same problem, I think it's a matter of compatibility between matcont and Matlab, I am now using Matlab 2012a and Matcont5, they are not the latest versions but they were both released in early 2012, and my problems are solved.

    Hope this works for you too,

    Last edit: efi12 2013-02-23

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.

No, thanks